This is working correctly.  The function name uses normal Rexx rules for name resolution.  If the call name is coded as a symbol, then the name being called is ALWAYS the uppercase version, since all symbols have as an eventual value the uppercase value of the symbol.  So calls to foo, Foo, and FOO are all calls to a function named "FOO".  This all happens before the search for an external function ever begins, so that code is not even aware of the original case.  The instruction itself has already folded the name to uppercase by execution time, so the original case is no longer available.  If a quoted string is used, then the original case is maintained. 


On Fri, Sep 21, 2012 at 7:03 AM, Jeremy Nicoll - ml sourceforge <> wrote:
There's been a long thread in comp.lang.rexx in the last few days from
someone trying to get external functions to work on an Ubuntu system.

This was ooREXX 4.1.2

The user's problem turned out to be due to him making function calls with
unquoted function names, which were folded to uppercase by oorexx and then
didn't match the actual file mixed-case leafnames - no surprise there.

But in the Ref manual section 7.2.1 about file search orders it says

  "Unix-based systems have a case sensitive file system, so files
   much be exact case matches in order to be located. For these
   systems, each time a file name probe is attempted, the name will
   be tried in the case specified and also as a lower case name."

The user did also, he says, try with the external function files named in
lower case.  You can check that if you want in his news post:

 Date: Thu, 20 Sep 2012 22:08:30 -0400
 From: "Cruz, Jaime" <Spammers@Bite.Me>
 Subject: Re: FINALLY got OOREXX working under Ubuntu!!
 Message-ID: <>

 Okay, I rebooted, edited out all the "SysAddRexxMacro" calls,
 then renamed all of the external functions in the directory to
 lower case.  That didn't work.

 Next, I renamed them to all upper case.  BINGO!  That worked!

I am unable to check this, not having any linux systems.  Can someone-else
tell if this is a search-order bug, or a documentation error?

The same user also has been questioning where the .deb-based install he did
put the oorexx documentation.  Anyone here know?

Jeremy Nicoll - my opinions are my own

Got visibility?
Most devs has no idea what their production app looks like.
Find out how fast your code is with AppDynamics Lite.;262219671;13503038;y?
Oorexx-devel mailing list