Thanks Staffan, this helps a lot.

On Thu, Feb 7, 2013 at 8:47 AM, Staffan Tylen <staffan.tylen@gmail.com> wrote:

This is what happens: I double click on ImageButton.rex and the dialog start, but almost immediately after the screen goes completely blank/black. I can tell that something starts to loop, because the CPU fan starts almost immediately after. Previously I tried to exit the situation but pressing various keys, but I've now tried waiting, and after about 20 secs the picture returns again. The DOS window or whatever it's called nowadays shows the following:

Got ideal size: a Size (63, 1111928)
  width:  63
  height: 1111928

This is where the problem is coming from.  On my system I get:

Got ideal size: a Size (181, 54)
  width:  181
  height: 54

Your height of the button look approximately 1,000 times the height of the screen.

The screen blanking and the CPU going are probably the result of the operating system trying resize the bitmap for the button to a thousand times the height of the screen.  Or comes from the operating system trying to paint that huge of a bitmap.

The rest of the stuff, distorted dialog, etc., is coming from the OS trying to draw the scaled bitmap.  At 32-bit color, the huge bitmap would need a lot of memory.

This gives me something to look at.  The size returned comes directly from the operating system though, so I'm not sure what the problem is.
 

I also tried to install the sourceforge version of ooDialog but it refuses to install, saying that I need to close the documentation and all oodialog applications, even after a fresh reboot! Don't know what's going on there.

Some process has either oodialog.pdf, oodguide.pdf, or oodialog.dll open so that it can not be deleted.  It could be one of those files is selected in Windows Explorer.  Or, maybe you have the documentation set to open on start up, or ...
 
--
Mark Miesfeld