#223 ooRexxUnit should have regular release versions

v4.0
closed
None
5
2012-08-14
2007-08-16
No

The ooRexxUnit framework is a very useful software package. I think we need to manage it in a better way.

As Rony and I were working on it, in svn head, we managed to let slip in some things that made it incompatible with the 3.1.2 release. This doesn't make sense because the people we are encouraging to get active writting test cases are not running the cutting edge latest ooRexx code, they are running the 3.1.2 release.

I think we should have regular check point releases for ooRexxUnit, and that they should match the ooRexx releases. I.e., if you are still running 3.1.2 when the 3.2.0 ooRexx is released, you should be able to easily get the 3.1.2 ooRexxUnit release that would be tested to be compatible with ooRexx 3.1.2

I also think it would be good to create actual release packages of ooRexxUnit that are placed in the files section.

This RFE is opened just to get the topic started. However we do it, I am not so concerned about, just that we do come up with a way of managing ooRexxUnit a little better.

Discussion

  • Mark Miesfeld

    Mark Miesfeld - 2008-07-04

    Logged In: YES
    user_id=191588
    Originator: YES

    With the snapshot packages and the branching of 3.1.0, 3.2.0, and trunk we have pretty much accomplished what this was about.

     
  • Mark Miesfeld

    Mark Miesfeld - 2010-09-16

    This request for a feature enhancement has been included in a prior release so the tracker item is being closed.

     


Anonymous

Cancel  Add attachments