32bit and 64bit versions of ooRexx on Win 7

  • Anonymous - 2011-09-26

    I have an application 'Pipelines' which runs just fine on Vista 32bit. It's
    been developed under VS2008 for a 32bit environment. I have someone helping to
    test the application - however they are reporting that their Win 7 will not
    work with the 32bit ooRexx version (only the 64bit). Do I need to produce a 64
    bit version of my application for it to work? I was under the impression that
    the 32bit version of ooRexx would run just fine under a 64bit Win7?

    Any comments/feedback would be much appreciated.

  • Paul Higgins

    Paul Higgins - 2011-09-26

    I have a very large application that runs fine on Win 7 using the 32 bit
    version of oorexx but it doesn't use Pipelines.

  • Anonymous - 2011-09-26


    Thanks for the reply.

    I wrote the Pipelines app. As I say it's 32bit and it lauches ooRexx through
    the RexxCreateInterpreter() function. Now it works just fine 32bit on my vista
    platform (32bit) - but my Win7 tester says that it will only allow him to
    install ooRexx 64bit.




  • Paul Higgins

    Paul Higgins - 2011-09-26

    I just tried the usepipe.rex sample program on my system and it works fine.
    Maybe you could ask your user to try it. Its in C:\Program Files
    (x86)\ooRexx\samples You have to open a command widow then do:

    cd C:\Program Files (x86)\ooRexx\samples

    then enter: usepipe

  • Anonymous - 2011-09-27

    Thanks for the reply.

    However, I am specifcally looking for anyone who may have experienced issues
    with 32bit ooRexx (not) running on a 64bit Win7 machine. My tester says and

    "But the 32 bit version of ooREXX does not function with Win 7 64 bit - only
    the 64 bit version works correctly (as in, at all)."

    Any advice would be most wecome (as I simply don't have access to a 64bit Win7
    machine to test with).



  • Mark Miesfeld

    Mark Miesfeld - 2011-09-27

    There is no problem running 32-bit ooRexx on a 64-bit Windows machine. I've
    done it on a dozen different systems, maybe more than a dozen.

    In addition, there are plenty of reports of people using 32-bit ooRexx on a
    64-bit Windows machine because they want to interface with something that only
    supplies 32-bit DLLs. DB2 comes to mind.

    Furthermore, no one has opened up a bug stating that ooRexx 32-bit doesn't
    work on 64-bit Windows. You should ask your tester to open up a bug and
    provide a detailed explanation of what he thinks the problem is, and how to to
    reproduce it.

    So far the information here doesn't make a lot of sense to me. A 32-bit
    process can not load a 64-bit DLL. So, your application, if it is 32-bit, can
    not load the 64-bit ooRexx DLLs.

    The best thing to do at this point is to open up a bug and provide the
    explanations I noted above. Simply saying ooRexx doesn't work, doesn't give
    the developers enough information to do anything about it. ;-)

    Mark Miesfeld

  • Anonymous - 2011-09-27

    I agree and appreciate that my post does not comprise any specific error codes
    or data. It was, however a very high level question and I thank you for your
    emphatic explanation that a 32bit app can call and use 32bit ooRexx on a 64bit
    Win7 machine.

    I'll get more information from the tester and report it.

    Many thanks.



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks