rexx, rexxc, and Windows 7 64-bit

2012-04-03
2012-08-14
  • Staffan Tylen

    Staffan Tylen - 2012-04-03

    I've installed what should be the 64-bit version of ooRexx but when I run
    "rexx -v" or "rexxc" it shows addressing mode 32. If I run "rexxc input.rex
    input.exe" and try to run the resulting load module, I get a message saying
    that the program is not compatible with the current operating environment.
    What am I missing?

    Thanks.

     
  • Bruce

    Bruce - 2012-04-03

    Well the most likely would be that you had a previous version of 32bit ooRexx
    installed. Is that a possibility?

     
  • Staffan Tylen

    Staffan Tylen - 2012-04-05

    bjskelly, you are spot on! How the mix-up has happened I don't know, but I
    uninstalled ooRexx, rebooted, and removed anything left behind, downloaded the
    64-bit version, installed with all default options, and voilá, now it say
    Addressing mode 64. Many thanks for this obvious tips!

     
  • Staffan Tylen

    Staffan Tylen - 2012-04-05

    It seems like I was too quick with my answer there. Yes, both "rexx -v" and
    "rexxc" show "Addressing mode: 64" but rexxc seems to generate a load module
    that still cannot be executed on my Windows 7 Ultimate 64-bit system. I get
    the following message when running it:

    Esta versión de C:\Users\St2430\Documents\Rexx\hello.exe no es compatible con
    la versión de Windows que está ejecutando. Compruebe la información de sistema
    del equipo para consultar si necesita una versión x86 (32 bits) o x64 (64
    bits) del programa, y después póngase en contacto con el editor del software.

    Google-translated:

    This version of C: \ Users \ St2430 \ Documents \ Rexx \ hello.exe not
    compatible with the version of Windows you are running. Check the computer's
    system information to see if you need an x86 (32 bit) or x64 (64 bit) program,
    and then contact the software publisher.

    Have I misunderstood how rexxc is working? I'm using command:

    rexxc hello.rex hello.exe

    to compile the program with no signs of any errors. The rexx program only
    contains

    say hello

    I execute it like this:

    hello.exe

    Another question I have about compiled rexx code: does the directive
    ::REQUIRES work if the required program is compiled with rexxc?

    Many thanks.

     
  • Rick McGuire

    Rick McGuire - 2012-04-05

    rexxc does not generate a .exe file. rexxc just generated a pre-parsed image
    of the rexx program that does not include the source. The resulting generated
    image still needs to be run by the rexx interpreter.

     
  • Staffan Tylen

    Staffan Tylen - 2012-04-05

    Ooops, that changes things! Many thanks. Now I can test myself if ::REQUIRES
    is supported. Great.

    Having mainframe background I'm quite excited about ooRexx, especially after
    running a simple rexx performance comparison, where my laptop outperformed a
    powerful IBM mainframe by about 100:1 !!!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks