#1163 ooDialog (rev 9048) crash

v4.2.0
closed
duplicate (4)
complete
1
2014-04-15
2013-02-28
No

A bug in my code creates an ooDialog crash as follows:

checkBox = self~newCheckBox(variable)

checkBox is set to .NIL because variable has an invalid value.

state = checkBox~getCheckState

CRASH.

The code is running in a PropertySheetPage dialog. Win7-64, ooDialog (32-bit) revision 9048.

Discussion

  • Mark Miesfeld

    Mark Miesfeld - 2013-02-28

    Hi Staffan,

    I need more to go on than this. On the face of it, what you show will not cause a crash. People get a return of .nil all the time using invalid resource IDs for a control:

    28 *-* state = checkBox~getCheckState
    

    Error 97 running C:\work.ooRexx\userDlg.rex line 28: Object method not found
    Error 97.1: Object "The NIL object" does not understand message "GETCHECKSTATE"

    So, the crash is not produced by the code you show. Something else is going on, but there is
    no hint in your report as to what it could be.

    You don't even mention whether you can reproduce the behavior.

    1.) Can you reproduce this on your system?

    2.) Can you attach an example program that produces the crash?

    3.) If you can not produce an example program, at least attach or insert the entire code for the method where your checkBox~getCheckState statement is executing in, with an explanation of how and when the method gets invoked.

    Thanks

     
  • Mark Miesfeld

    Mark Miesfeld - 2013-02-28

    Oh, I forgot to add this. If you can reproduce the crash on your system, please try the build I put up on SourceForge under the preview section and see if the crash goes away.

    Thanks.

     
  • Mark Miesfeld

    Mark Miesfeld - 2013-02-28

    Staffan,

    I put a 32-bit ooRexx 4.1.2 on my Windows 7 system. Used a property sheet dialog with 5 pages, and tested in each page dialog:

    C:\work.ooRexx>PropertySheetDemo.rex
    going to test
    166 - state = checkBox~getCheckState
    Error 97 running C:\work.ooRexx\PropertySheetDemo.rex line
    166: Object method not found
    Error 97.1: Object "The NIL object" does not understand message "GETCHECKSTATE"

    So, without more information from you there is nothing more I can do with this.

     
  • Mark Miesfeld

    Mark Miesfeld - 2013-12-08

    This bug has the same root cause as: [bugs:#1186] ooRexx/oodialog will either hang or crash from deadlock condition

    Although the title is a litter misleading. The deadlock was a bug in the user's code. It is the crash we are concerned with. The cause of the crash was fixed in 4.1.fixes and has been fixed in trunk for a long time.

     

    Related

    Bugs: #1186

  • Mark Miesfeld

    Mark Miesfeld - 2013-12-08
    • labels: --> duplicate
    • status: open --> pending
    • Pending work items: none --> complete
    • Group: None --> v4.2.0
     
  • Mark Miesfeld

    Mark Miesfeld - 2013-12-08
    • assigned_to: Mark Miesfeld
     
  • Rick McGuire

    Rick McGuire - 2014-04-15
    • status: pending --> closed
     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks