#1123 Gap in results from SysFileTree

4.1.2
closed
duplicate (4)
none
3
2012-10-07
2012-10-06
Swifty
No

Windows 7 Ultimate x64
Open Object Rexx Version 4.1.2
Build date: Aug 28 2012
Addressing Mode: 64

In a routine with code:

Mask = 'D:\ProgramData\webcamXP 5\WWWRoot\Gallery*'
Call SysFileTree mask,'F.','FL'
Say '['F.0']'
If F.0 > 0 then call SysStemSort 'F.'

I'm getting:

[111476]
... then a Syntax error in SysStemSort

This is because variables F.52152 to F.52159 (inclusive; 8 files) were undefined.

I have checked the actual directory, and the 8 files missing from the stem are NOT missing on disk; they are still there, and have been for a couple of weeks. Thus they weren't erased whilst SysFileTree was running.

So, I wrote a test program to execute just the code above, and it works. So, I re-ran the original program, and that now works. So the problem is intermittent.

You have my sympathy trying to find the cause of this. The original program is still running, in "Trace ?r" mode, in its' Syntax handler, but my system will Auto-reboot if left too long, so if you want any details that I can extract, you'll have to ask quickly.

Discussion

  • Swifty

    Swifty - 2012-10-06

    I missed a "\" in my code example, which should have read:

    Mask = 'D:ProgramData\webcamXP 5WWWRootGallery*'

     
  • Swifty

    Swifty - 2012-10-06

    Ah, now I see. All "\" characters are being dropped...

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-10-06

    Hi Steve,

    First off, the "\" problem bit me also. It's because this entry is actually using markdown. You can get around it by using the back tick to quote the path name. I believe clicking on the formatting help will give you other options.

    C:\myPC\myDisk\myFolder

    More to the point of the bug. This is actually a duplicate of: #1021 SysFileTree usage Access Violation [Bugs:#1021]

    If you read through that, you'll see that the submitter had actually worked through to the same problem you saw, that some of the tails are not defined.

    There have actually been a number a number of, 4 or 5, bugs related to SysFileTree that have plagued us.

    The implementation code for SysFileTree has been reworked and we believe these bugs are fixed.

    The fix will be in the next release. With this bug, it is hard to be sure because I could never produce it at all. And for the people who could produce it, it was very random. However, the submitter of bug #1021 could seemingly always reproduce it if he ran his test long enough. He tested for us with a build that included the reworked SysFileTree and could never produce the bug. This is our basis for thinking it is fixed.

    I'm going to close this as a duplicate. Not sure what the next release version will be, either 4.1.2 or 4.2.0. Please open a bug in the future if you see this problem with the next release.

    • labels: --> duplicate
    • status: open --> closed
    • assigned_to: Mark Miesfeld
     
  • Mark Miesfeld

    Mark Miesfeld - 2012-10-06

    Closing as a duplicate. [tickets:#1021]

    (Trying to link to 1021, my previous attempt failed. Not sure if the above will work or not.)

     
  • Swifty

    Swifty - 2012-10-07

    I'm on 4.1.2, I think installed as a beta when I got this new PC. I hope that doesn't mean that I've found a bug in the new code.

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-10-07

    Sorry Steve, I had a typo in my comment. The reworked code is not in a release version. It will be in the next release. Whether we will call that 4.1.3 or 4.2.0, is not decided yet.

    My clumsy fingers typed 4.1.2, but I meant 4.1.3.

     
  • Swifty

    Swifty - 2012-10-07

    Well, that's good news for me, as I'm hoping that the new SysFileTree code
    will fix the problem.

    On 7 October 2012 08:40, Mark Miesfeld miesfeld@users.sf.net wrote:

    Sorry Steve, I had a typo in my comment. The reworked code is not in a
    release version. It will be in the next release. Whether we will call
    that 4.1.3 or 4.2.0, is not decided yet.

    My clumsy fingers typed 4.1.2, but I meant 4.1.3.

    • bugs:1123 Gap in results from SysFileTree*

    Status: closed Labels: duplicate Created: Sat Oct 06, 2012 04:06 AM
    UTC by Swifty Last Updated: Sun Oct 07, 2012 04:20 AM UTC Owner: Mark
    Miesfeld

    Windows 7 Ultimate x64
    Open Object Rexx Version 4.1.2
    Build date: Aug 28 2012
    Addressing Mode: 64

    In a routine with code:

    Mask = 'D:ProgramDatawebcamXP 5WWWRootGallery*'
    Call SysFileTree mask,'F.','FL'
    Say ''F.0''
    If F.0 > 0 then call SysStemSort 'F.'

    I'm getting:

    111476
    ... then a Syntax error in SysStemSort

    This is because variables F.52152 to F.52159 (inclusive; 8 files) were
    undefined.

    I have checked the actual directory, and the 8 files missing from the stem
    are NOT missing on disk; they are still there, and have been for a couple
    of weeks. Thus they weren't erased whilst SysFileTree was running.

    So, I wrote a test program to execute just the code above, and it works.
    So, I re-ran the original program, and that now works. So the problem is
    intermittent.

    You have my sympathy trying to find the cause of this. The original
    program is still running, in "Trace ?r" mode, in its' Syntax handler, but
    my system will Auto-reboot if left too long, so if you want any details
    that I can extract, you'll have to ask quickly.


    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/oorexx/bugs/1123/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/prefs/

    --
    Steve Swift
    http://www.swiftys.org.uk

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks