#1114 ooSQLite causes rexxpaws abnormal termination

ooSQLite.preview
closed
ooSQLite (10)
none
1
2012-10-02
2012-09-20
No

I try to run the following statements using the exec method but ooRexx 4.1.2 (32bit) abnormally terminates:

callBack = .TRUE
resultSet = dbConnection~exec("PRAGMA table_info(" || tablename || ");", callBack)

If I run without the 2nd argument, return code zero is returned. Error details from the event log are as follows:

rexxpaws.exe
4.1.2.8305
503d7f0b
oosqlite.DLL
0.0.0.0
504eada5
c0000005
00063a7f
20cc
01cd97762dd46af1
C:\Program Files (x86)\ooRexx\rexxpaws.exe
C:\Program Files (x86)\ooSQLite\bin\oosqlite.DLL
70d403af-0369-11e2-b412-f0bf9765b8be

Windows 7

Discussion

  • Staffan Tylen

    Staffan Tylen - 2012-09-20

    btw, the error only happens if the specified table exists.

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-21
    • labels: --> ooSQLite
    • status: open --> accepted
    • assigned_to: Mark Miesfeld
     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-21

    Staffan,

    I'm going to need more information on this. I can't reproduce this at all. It's always best if you attach a short working program that demonstrates the bug.

    By the way, the other bug you noted on the user's mailing list, is a bug.

    For this bug, I'm going to attach two different test programs, both of which work fine for me. I'm assuming they'll work for you, but it would be best to know for sure.

    I realize it is not always possible to attach a program that demonstrates a bug, but I at least need a description of what you are doing that is different than what my tests do. A working program is always better than descriptions.

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-21

    Sample program that works using the result set as an array of directories.

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-21

    Sample program that works using the result set as an array of arrays.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous

    Anonymous - 2012-09-21

    execPragmaTestA works fine. execPragmaTestD however does not, it gives the following result:

    58 *-* resultSet = dbConn~pragma('table_info', tablename)
    

    Error 48 running C:\Users...\execPragmaTestD.rex line 58: Failure in system service
    Error 48.900: failed to allocate memory

    It runs using rexxpaws.

    Open Object Rexx Version 4.1.2
    Build date: Aug 28 2012
    Addressing Mode: 32

    ooSQLiteVersion: 3.7.14

    Windows 7 Ultimate (64bit, SP1), 6GB RAM

    As for the original bug, the following code causes the abnormal termination of ooRexx as described above. 'sqltest.db' was created using oosqlite3 and the following SQL command:

    CREATE TABLE TABLE1 (A,B);

    BTW, I have not yet tested any of this using 64bit versions of the ooRexx/ooSQLite.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous

    Anonymous - 2012-09-21

    Sorry forgot the code:

    db=.ooSQLiteConnection~new("sqltest.db")
    callback=.true
    resultset = db~exec("PRAGMA table_info(table1);", callback)

    ::requires "oosqlite.cls"

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-22

    Staffan, this:

    "execPragmaTestA works fine. execPragmaTestD however does not, it gives the following result:
    58 - resultSet = dbConn~pragma('table_info', tablename)
    Error 48 running C:Users...execPragmaTestD.rex line 58: Failure in system service
    Error 48.900: failed to allocate memory"

    is of course your other bug. It is fixed now.

    As for this bug, it is interesting, in that it does not happen with a debug build. However it did crash when I ran it with a non-debug build. That will make it hard to track down.

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-22

    Committed revision [r8434]

    Staffan, thanks for finding this and reporting it. It is fixed now. Look for a new build of ooSQLite on SourceForge tomorrow.

     

    Related

    Commit: [r8434]

  • Mark Miesfeld

    Mark Miesfeld - 2012-09-22
    • status: accepted --> pending
     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-22
    • status: pending --> closed
     
  • Mark Miesfeld

    Mark Miesfeld - 2012-09-22

    This fix is available in ooSQLite Version 1.0.0.8435 (Preview)

     
  • Staffan Tylen

    Staffan Tylen - 2012-09-22

    Mark, Thanks. However, I downloaded 8435 for Win 32bit and the bin folder
    is unfortunately empty.

    Staffan

    On Sat, Sep 22, 2012 at 7:12 AM, Mark Miesfeld miesfeld@users.sf.netwrote:

    • status: pending --> closed

    • bugs:1114 ooSQLite causes rexxpaws abnormal termination *

    Status: closed Labels: ooSQLite Created: Thu Sep 20, 2012 09:46 PM
    UTC by Staffan Tylen Last Updated: Sat Sep 22, 2012 04:13 AM UTC Owner:
    Mark Miesfeld

    I try to run the following statements using the exec method but ooRexx
    4.1.2 (32bit) abnormally terminates:

    callBack = .TRUE
    resultSet = dbConnection~exec("PRAGMA table_info(" || tablename || ");",
    callBack)

    If I run without the 2nd argument, return code zero is returned. Error
    details from the event log are as follows:

    rexxpaws.exe
    4.1.2.8305
    503d7f0b
    oosqlite.DLL
    0.0.0.0
    504eada5
    c0000005
    00063a7f
    20cc
    01cd97762dd46af1
    C:Program Files (x86)ooRexxrexxpaws.exe
    C:Program Files (x86)ooSQLitebinoosqlite.DLL
    70d403af-0369-11e2-b412-f0bf9765b8be

    Windows 7

    Sent from sourceforge.net because you indicated interest in
    https://sourceforge.net/p/oorexx/bugs/1114/

    To unsubscribe from further messages, please visit
    https://sourceforge.net/auth/prefs/

     
  • Mark Miesfeld

    Mark Miesfeld - 2012-10-02
    • milestone: None --> ooSQLite.preview
     

Anonymous
Anonymous

Cancel  Add attachments