Debian Etch Installation

Help
xt4mhz
2007-10-02
2013-05-01
  • xt4mhz

    xt4mhz - 2007-10-02

    Hi.

    I hope somebody can help me.

    I downloaded "OOOP_2.2.0_070417_unxlngi6_install.tar.gz". After I extracted a few "debs" came out. I didnt see any "README" or something to install de package or to read some advices.

    I have Debian Etch with OpenOffice 2.0.4. I am interested in use Oxygen but I dont know if I have to uninstall the openoffice that comes with Debian Etch.

    Do I have to uninstall Open Office installed by default ?
    That is the sequence to install all "debs" ?...or just have to "dpkg -i *.deb" ?
    Besides templates and graphics: why I should use Oxygen instead Open Office 2.0.4 ?

    Thanks a lot.

    xt4mhz

     
    • xt4mhz

      xt4mhz - 2007-10-03

      Well ... after a big fight downloading the package I can answer by myself some questions:

      1. "Do I have to uninstall Open Office installed by default ?"
      Yes, I uninstalled all packages related with previos version of OpenOffice that comes with Etch.
      How?
      I did: "aptitude purge openoffice.org"
      Checked if there was another packages doing: "aptitude search openoffice
      Uninstalled any package related with openoffice.org.

      2) "That is the sequence to install all "debs" ?...or just have to "dpkg -i *.deb" ? "
      Yes. I did: "dpkg -i *.deb"
      Then changed to "desktop-integration" folder and did the same thing.

      3) Besides templates and graphics: why I should use Oxygen instead Open Office 2.0.4 ?
      I have no idea yet. I will get into oxygen deeply to see what can I find.

      Thanks.

       
      • dinger1986

        dinger1986 - 2007-10-03

        Sorry for not replying, i would personnally have suggested you leave openoffice on and simply install the extensions for openoffice, save yourself the hassle. But you have done it so its all good, again i apologise for not getting back sooner.

        Regards,
        Daniel

         
    • Lance W. Haverkamp

      Simply running:

      # ./update

      should work (and does work in OpenOffice), but it does not work in OxygenOffice.  Doing so made my OpenOffice/OxygenOffice installation completely non-functional.  I too will do a complete uninstall:

      # apt-get remove openoffice*

      for those who don't run aptitude.

      > i would personnally [sic] have suggested you leave openoffice on and simply install the extensions for openoffice

      Where are the instructions for this...and does that enable the M$Office 2007 compatibility?

      Thanks,  It looks interesting.

      Lance

       
    • Lance W. Haverkamp

      I uninstalled OpenOffice & installed OxygenOffice; it still did not work at all. 

      $ ./openoffice.org2.4

      returns:

      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libuno_sal.so.3)
      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libuno_cppu.so.3)
      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libuno_cppuhelpergcc3.so.3)
      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libjvmfwk.so.3)
      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libstdc++.so.6)
      /etc/openoffice.org2.4/program/javaldx: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libstlport_gcc.so)
      /etc/openoffice.org2.4/program/pagein: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /etc/openoffice.org2.4/program/pagein)
      /etc/openoffice.org2.4/program/pagein: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libstdc++.so.6)
      /etc/openoffice.org2.4/program/oosplash.bin: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /etc/openoffice.org2.4/program/oosplash.bin)
      /etc/openoffice.org2.4/program/oosplash.bin: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libuno_sal.so.3)
      /etc/openoffice.org2.4/program/oosplash.bin: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /opt/openoffice.org2.4/program/libstdc++.so.6)

      I believe Debian Etch includes 2.2, not 2.4, so it seems that OxygenOffice is not compatible with the currently stable version of Debian.  Genuine OpenOffice does not share this problem.

      Lance

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks