libtool version mismatch

raghu
2010-12-27
2013-06-05
  • raghu

    raghu - 2010-12-27

    I get libtool version mismatch when I build mad under extern_components/mad in bellagio-0.9.2.1
    I ran:
    autoreconf -i
    ./configure -prefix=$HOME/lib
    make

    libtool: Version mismatch error.  This is libtool 2.2.6b, revision 1.3012,
    libtool: but the definition of this LT_INIT comes from revision 1.3017.
    libtool: You should recreate aclocal.m4 with macros from revision 1.3012
    libtool: of libtool 2.2.6b and run autoconf again.

    The version of libtool I am using is 2.2.6b

    Regards,
    Raghu S

     
  • raghu

    raghu - 2010-12-28

    Problem seems to be solved when I delete the libtool from the extern_components/mad directory and create a softlink from /usr/bin/libtool
    Is this something that has to be fixed in the next release of the code?

     
  • Giulio Urlini

    Giulio Urlini - 2011-01-26

    Hi Raghu S,
         I've checked in the actual development tree and the libtool file has been removed.
    Since it is depending on the libtools version, is is created by the autotools.

    Thanks and regards,

    Giulio

     

Log in to post a comment.