gst-openmax-0.10.0.4

2008-11-04
2013-06-05
  • valeswararao

    valeswararao - 2008-11-04

    hi all

    now i am install the gst-openmax-0.10.0.4

    when enter the command omxregister -v 

    it shows like thsis only 4 components are registered

    Component OMX.st.audio_decoder.ogg.single registered
    Specific role OMX.st.audio_decoder.ogg.single registered
    OMX-could not load /usr/local/lib/omxilcomponents/libomxffmpeg.so: /usr/local/lib/omxilcomponents/libomxffmpeg.so: undefined symbol: av_log
    Component OMX.st.audio_decoder.mp3.mad registered
    Specific role OMX.st.audio_decoder.mp3.mad registered
    Component OMX.st.volume.component registered
    Specific role OMX.st.volume.component registered
    OMX-could not load /usr/local/lib/omxilcomponents/libomxfilereader.so: /usr/local/lib/omxilcomponents/libomxfilereader.so: undefined symbol: av_log
    Component OMX.st.fbdev.fbdev_sink registered
    Specific role OMX.st.fbdev.fbdev_sink registered
    4 OpenMAX IL ST static components with 4 roles succesfully scanned

    how to get the all components 

    how to set this problem.....? 

    thanks&regards
    d.valeswararao

     
    • Pankaj Sen

      Pankaj Sen - 2008-11-04

      Hi valeswararao,

      The problem you faced has no relation with gstreamer. So, the subject topic is ambiguous.

      you did not able to register components ?

      av_log is a function in ffmpeg library and not used in openmax implementation.

      You might have multiple ffmpeg library and header installation. If yes, then clean up unused installation or use LD_LIBRARY_PATH to specify which library you want to use. You may have to specify header file path while configuring openmax.

      Regards,
      Pankaj

       
    • valeswararao

      valeswararao - 2008-11-04

      Hi pankaj,

      Thanks for your reply.

      thanks&regards
      d.valeswararao

       
    • Giulio Urlini

      Giulio Urlini - 2008-11-05

      Hi,
      unfortunately your problem seems to be related to a wrong verison of ffmpeg that does not support av_log function. The ffmpeg is not based on official releases, so I don't have a release to suggest. Maybe you can try with the latest code from svn for ffmpeg.
      Best Regards,
      Giulio

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks