Webcam does not function

Help
Brent
2007-01-30
2013-04-11
  • Brent

    Brent - 2007-01-30

    I read the post in the general discussion, and don't understand what you mean by "webcam port".  My webcam is available to apps like Yahoo IM. But there is nowhere in its (logitech) software to configure a webcam port. This is connected to a USB. If I leave omnimeeting at the default input port of 0, absolutely nothing happens once I start the server. The camera has an indicator LED that should turn on. This is windows 2000.

    If I try to connect to the server, the client gets an error "Error getting SDP description from URL"

    Any help would be appreciated.

     
    • Massimo Cora'

      Massimo Cora' - 2007-01-30

      OpenCV maps input ports as "0", "1", "2" etc.. So a "webcam port" is one of those.
      That's strange that no led turns on. I've made tests with Logitech and Philips webcams, and in both the led turns on. Have you tried setting the "port" to "1"? Have you got other video input devices connected to your pc?

       
    • Brent

      Brent - 2007-02-01

      I've tried ports 0, 1 & 2. No luck on any. 

      I've also switched to using the XP box as the RTSP server and a 2000 box as the client. I no longer get any errors. But now the server says "Start Streaming..." and the client says "Start receiving..." but the webcam never turns on.

      I have no other active video devices on either. Camcorders have previously been connected, but not now. But those were through firewire.

      I don't know if I missed something. What I do is
      1) Launch Omnimeeting.exe (FYI: there's a typo in either the window title, or the .exe name)
      2) Select Tools -> Preferences
      3) Enable "Stream SubSession" as testStream, Leave "Grab Webcam" enabled, enable "Grab Audio"
      4) Sometimes play with the IP addresses at the bottom
      5) Click OK

      I've also tried launching the Logitech software either before step 1, or after step 5. Either of these turns on the LED on the camera, but doesn't get a stream to the other PC.  For yahoo IM I don't need to touch the Logitech app, so I don't think I need to here either.  Camera is a QuickCam fusion which seems to be supported by OpenCV through linux, hopefully it is through windows too.

      On the other side:
      1) Launch Omnimeeting.exe (FYI: there's a typo in either the window title, or the .exe name)
      2) Select Tools -> Preferences -> Client Stream
      3) Set RTSP://<correct ping-able IP>:8554/testStream
      4) Enable "Connect and receive stream(s)" and leave audio enabled
      5) Click OK

      But overall things are better with the XP as the server instead of windows 2000. No more crashes or error messages. So that was probably part of my problem last time.

      Thanks for the help.

       
    • Massimo Cora'

      Massimo Cora' - 2007-02-01

      Hi,
      hmm there's obviously a bug somewhere. Your procedure to activate server/client is correct, but something is broken at cam-management side. "Unfortunately" on my system it works and I cannot be much of help to you :-/ There would need some deeper debug with Visual Studio, and then the bug would be squashed. Anyway did you try to stream some videos? If you had xvid codecs installed you could stream videos that come with Omnimeeting to see if the connections between server-client works correctly.

      Thanks and regards,

      Massimo

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks