Missing EncoderFactory for IEEE1516eRtiFactory?

2014-04-03
2014-04-05
  • Paul Grogan

    Paul Grogan - 2014-04-03

    I am curious why there is a null return value for the getEncoderFactory() method in IEEE1516eRtiFactory as of OHLA 0.6. Does this indicate there are no implementations yet of the IEEE 1516e data types yet checked in?

     
  • Michael Newcomb

    Michael Newcomb - 2014-04-03

    I have yet to implement those. I will add them to the list of things for 0.7.

    I'm almost done with 0.6.1 which fixed a few things and changed the serialization to use Google Protocol Buffers in preparation for the C++ interface.

     
  • Paul Grogan

    Paul Grogan - 2014-04-04

    I have some completed implementations based in part on the 1516 jlc classes (with appropriate additions). I haven't verified the implementation against the standard but it appears to work in practice and I'd be happy to contribute them. Thanks for your continued work on this project, I've been using it off-and-on over the past couple of years.

     
  • Michael Newcomb

    Michael Newcomb - 2014-04-05

    You can send me the files you want to contribute and I'll add them in for the next release.

    Glad to hear that you are making some use of the project!

     
  • Paul Grogan

    Paul Grogan - 2014-04-05

    I've attached the files here... it was actually a while ago that I did a bulk of the transplanting from the jlc classes. There are a couple new methods required for the 1516e interface and a couple new data types. I referenced the standard to get the correct encoding structure, however I don't recall the extent to which I actually tested the code. Anyways, hope it's helpful!

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks