X264 option test

Forty
2013-12-28
2014-02-03
  • Forty

    Forty - 2013-12-28

    Hello,

    I noticed that on startup ogmrip do some mencoder tests.
    for example:
    mencoder -nocache -nosound -quiet -frames 1 -rawvideo pal:fps=25 -demuxer rawvideo -o /dev/null -ovc x264 -x264encopts bime:bitrate=800:threads=1 /dev/zero
    to test the "bime" option.
    Unfortunatly on my system this command never returns (the CPU starts working 100% on encoding /dev/zero)
    I have noticed that changing the command to -frames 0 makes it return immediatly and produce the error excpeted by ogmrip "Option x264encopts: Unknown suboption bime"

    It is a bug in ogmrip or is this a problem with my mencoder version?

    mencoder: MPlayer SVN-r36533
    ogmrip: 1.0.0
    both installer on debian testing with the deb-multimedia repo enabled

    Thanks

     
    • pij

      pij - 2014-01-05

      Upgrading ogmrip to 1.0.0-dmo3 seems to help for ogmrip at least. The changelog mentions some obsolete options but nothing about -nosound.

       
      • pij

        pij - 2014-01-05

        Well, that was a bit premature, autocrop or preview for manual cropping which uses mplayer still doesn't work.

         
  • Forty

    Forty - 2013-12-28

    similarly, I have problems with all commands that use the -nosound option of mplayer:
    mplayer -nolirc -nocache -nosound -nozoom -nosub -vo jpeg:outdir=/tmp -frames 1 -speed 100 -ss 28 -dvd-device /home/forty/DVD dvd://1

    Using -ao null instead seems to make it work.

     
  • Olivier Rolland

    Olivier Rolland - 2014-01-03

    What is your version of mplayer/mencoder?

     
    • pij

      pij - 2014-01-05

      This ought to be 1.1.1 + SVN r36533 (i.e. unreleased) as packaged for debian by deb-multimedia.org (I have the same problem)

       
  • Gianluca Sforna

    Gianluca Sforna - 2014-01-12

    mplayer version: mplayer-1.1-16.20131125svn.fc20.x86_64

     
  • infopipe

    infopipe - 2014-01-29

    Same on opensuse:
    Name: MPlayer
    Version: 1.1.1.r36557-1.3
    Arch: i586

     
  • Olivier Rolland

    Olivier Rolland - 2014-02-01

    I still don't know what the problem exactly is but I have a workaround. Please try [patches:#41].

     

    Related

    Patches: #41

  • Gianluca Sforna

    Gianluca Sforna - 2014-02-03

    Worked for me. Thanks!

     

Log in to post a comment.