#2 OpenGL >3.0 context failed - message

First move
closed
nobody
2013-02-12
2012-12-18
pet_cz
No
  • Get the number of highest possible context version before creating the context itself (using some dummy context)
  • Allow to create the highest possible context
  • Allow to create higher version if the requested version failed (e.g. 3.1 is not working but 3.2 is ok)

Discussion

  • pet_cz

    pet_cz - 2013-02-12
    • not necessary, problems are caused by NVidia driver, not respecting the specification:
      "If the requested OpenGL version is less than 3.2, WGL_CONTEXT_PROFILE_MASK_ARB is ignored and the functionality of the context is determined solely by the requested version."
     
  • pet_cz

    pet_cz - 2013-02-12
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks