glLineWidth not work on OpenGL ES 1.x Vincent

  • Techgeo Techgeo

    Techgeo Techgeo - 2009-10-21

    Hello everybody,
    I'm using the OpenGL ES 1.x Vincent in a software I'm developing and I am not able to change the width of the line with the function glLineWidth. I develop in Windows environment (Visual Studio 2005) for devices with Windows Mobile / CE. Does anyone have any idea what might be happening? I'm already thinking that this function is not implemented in this library. Hugs

  • ffelagund

    ffelagund - 2009-10-22

    Working with iPhone's GL|ES implementation, I discovered (after reading the docs) that line segments with a width larger than 1 were not allowed. This could be same case in this GL|ES implementation. Lets wait for an official reply :)

  • Techgeo Techgeo

    Techgeo Techgeo - 2009-10-22

    Does the output to draw a line width greater than 1 will be to draw two triangles?

    I think in my project will not be viable. Changing the width of line does not work with your own example available here at SourceForge (ogl-es-samples -> 0.82 -> called lines (in the way archive: ogles-0.82-samples \ redbook \ eVC4 \ lines.vcp).

    The strange thing is that on google I'm not finding someone with similar problems.
    Please someone help me. I will be grateful.

  • matthew tsai

    matthew tsai - 2009-11-23

    it seems some proble with the opengl es, i have tried to change the linewidth too, but it not work and i am trying to make drawpoint as a circle, but it still not work, but all the function i tried in pc opngle is work properly, is there some function not implement ? anyone can give a answer please


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks