#7 Bug with ZipArchive since PHP 5.3.7

closed
None
5
2009-06-19
2009-05-15
No

Since PHP 5.2.7, the archive copression with Zip extension make troubles for ODT documents. The generated ODT document will be corrupted. This bug was confirmed by the php-zip author. It should be fixed in the next version of Zip.

Discussion

  • PIERRE de GEYER

    PIERRE de GEYER - 2009-05-18
    • assigned_to: nobody --> neveldo
     
  • Vincent Brouté

    Vincent Brouté - 2009-06-19
    • status: open --> closed
     
  • Vincent Brouté

    Vincent Brouté - 2009-06-19

    We have developped a proxy system that allows you to choose between the PclZip library or the PHP Zip extension in order to handle Zip compression. By default, PclZip is used by default so odtPHP works in any cases now.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks