3 Bugs in 0.5.0! In marc uploads, Del Record.

2004-09-17
2013-05-30
  • Nobody/Anonymous

    These are the few Errors I am facing using your OpenBiblio version 0.5.0 database version 0.4.0 system. I am using Xeneo Web Server 2.2.22.0 with PHP 4.3.1.1. I am running mysql database version 4.0.20d

    I have tested them both in windows XP 32-bit Service Pack1 and Windows Advanced Server with serice pack 4 and with other webservers also and I am encountering similar problems everywhere. You software is really good working perfectly expect for these buggy messages. I only face these problems in the Admin Mode and normal search mode is absolutly great and no problems. In the admin mode all other functions are perfectly working except for these buggy messages.

    Problem 1:

    I logon to Admin mode by entering my username and password.

    Goto Cataloging and then when I say upload Marc Data with the following options

    Test Load: True [I am just testing it]
    USMarc Input File: [I gave a mark21 format file converted from OCLC marc editor]

    Defaults: Collection:  Urdu Reference Collection 
    Type of Material:  Books 
    Show in OPAC: Yes

    I get the following errors. These 3 notices repeat for a couple of more lines. Although after the test load i run the marc uploader again for real uploads, I AM ABLE TO UPLOAD DATA and work perfectly only thing is these messages are a bit bugging. Is there any way you could correct these notices in your future releases.

    Notice: Undefined offset: 10 in C:\Xeneo\ob5\catalog\upload_usmarc.php on line 71

    Notice: Uninitialized string offset: 0 in C:\Xeneo\ob5\catalog\upload_usmarc.php on line 77

    Notice: Undefined offset: 10 in C:\Xeneo\ob5\catalog\upload_usmarc.php on line 80

    Problem2:

    When I search for Bibliography Search, I am thrown up some  Search Results which very good. But when i select any one Search Results and try to delete it i get the following warning but the record is deleted succesfully.

    Are you sure you want to delete the bibliography with title
    Notice: Undefined variable: title in C:\Xeneo\ob5\navbars\cataloging.php on line 47
    ?
    [DELETE] or [CANCEL]

    I press delete and the record is deleted but this a buggy message that is displayed.

    Bibliography,
    Notice: Undefined variable: title in C:\\Xeneo\\ob5\\navbars\\cataloging.php on line 47
    , has been deleted.

    [return to bibliography search]

    I think the problem is that its trying to display the title of the record its deleting but for some reason not able to delete.

    Even you try correcting it in the sepcified file same error pops up on line 113. I think this problem has to do with not including the variable name title in certain file.

    Problem 3:

    In reports, Print Labels  Print Letters

    there is something called

    1.Over Due Letters

    When i press on it nothin happens. Is it an error?

    Similarly for Reports Summary  Report List

    6.Over Due Member List gives no response when i press on the hyper link.

    I am sorry for troubling you but your product is great and we wish to fully implement it and hope to support it fully in terms of the development with whatever monetary and testing support we can.

    Thank YOu
    Rahul Atlury

     
    • Micah Stetson

      Micah Stetson - 2004-09-17

      Thanks for the reports!

      Problem 1:
      There are known inadequacies with the MARC functionality (import, editing and storage), and it will probably be rewritten completely for the next release.  That rewrite should take care of the problem you're having.

      Problem 2:
      This is bug 1010625 and has already been fixed in CVS.

      Problem 3:
      I'm not sure what's happening here.  The problem doesn't occur for me.  Is there any more info you can provide?  What are the addresses those links point to?  Does anything change at all?

      Don't worry about troubling us, we want to know if things are wrong.

      Micah

       
    • Nobody/Anonymous

      Thanks for the reply, I have been out of town for while so could not reply on time. I will check for the third problem more thoroughly and let u know.

      Btw when is the next release expected?

      Also i hope marc editor is updated well coz it not displaying romanized urdu records very well.

      Thanks for all hardwork anyway!
      Rahul

       
      • Micah Stetson

        Micah Stetson - 2004-09-30

        We learned our lesson about announcing release dates after the 0.5.0 delays  But truthfully, we haven't discussed it much.  Our current work for 0.6.0 involves some big changes, though, so we will probably make a bug-fix release (say 0.5.1) before that.

        The MARC editor is something I'm working on right now.  But the MARC-8 character encodings are not a high priority for me, and they're more than I have time for at the moment.  Until someone gets the time and inclination to add character-set conversion support, your best bet is to use an external tool to convert your MARC-8 records to UTF-8 before you import them to OpenBiblio.  Then set the character set to UTF-8 in the admin interface.  This should just work, but I haven't actually tried it.

        Micah

         
        • Nobody/Anonymous

          A bug fix release would help my work (no need to fetch CVS files). New releases ensure that the project is alive, too. Are you going to add new translations (if any?) to the bugfix release?

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks