Lookup updated as of 8 Apr 2005

2005-04-08
2013-05-30
  • Fred LaPlante

    Fred LaPlante - 2005-04-08

    - Major change is ability to do a search by title & author. Also if multiple hits result from any search you will receive a short list of all hits from which you can cut & paste ISBN or LCCN & Author and immediately do a new search.

    - Second change is facility for auto assignment of a user supplied default Dewey call number to fiction if none is found by a search.  (Fiction is determined from LC 'PS' or 'PZ' classification code) You can also have a  cutter code, of the form 'Axxxa', added to this Dewey, either LC type, or Cutter-Sanborn 3-digit (thanks to Christopher Dagleish of Bavaria for that).

    - User configuration material broken out into a seperate lookup_conf file.

    - user may specify a user ID and password for Z3950 server access.

    - Installation procedure seperated from release notes.

    - new mysql table for Cutter - Sanborn codes.

    - A number of small bug fixes.

    Comments or enhancements appreciated.  Also I am curious as to how many are using this add-on.

    Fred LaPlante
    flaplante@flos-inc.com
    - -

     
    • dude4linux

      dude4linux - 2005-05-10

      Fred,

      The latest lookup_install.txt is missing a '{' from the end of the line

      if (!isset($HTTP_GET_VARS["lookupVal"]) && !isset($HTTP_GET_VARS["srchBy"]))

      Also when using 0.5.1, I had to comment out the following line in biblio_new_form.php because it kept looping back to the login.

      require_once("../shared/logincheck.php");

      Lastly how are supposed to install the mysql table for Cutter-Sanborn codes?

      TIA - John

       
      • Fred LaPlante

        Fred LaPlante - 2005-05-11

        >> The latest lookup_install.txt is missing a '{' from the end of the line

        Sure is. Good catch.  It will be fixed in all future releases.

        I have been using 0.51 both at home and the local public library for some time now.  Hadn't run int the problem you describe. The line
        require_once("../shared/logincheck.php");
        is active in both cases here.

        MySQL will use any table present in the "database" directory.  So just copy the cutter table to  .../MySQL/Data/OpenBiblio
        Couldn't be easier.

        Fred

         
    • Nobody/Anonymous

      I moved the Cutter files to the correct location and then tried uncommenting the line
      require_once("../shared/logincheck.php");
      but still no luck.  My modified biblio_new_form.php starts off like this:

        session_cache_limiter(null);

        $tab = "cataloging";
        $nav = "new";
        $helpPage = "biblioEdit";
        $cancelLocation = "../catalog/index.php";

              if (!isset($HTTP_GET_VARS["lookupVal"]) && !isset($HTTP_GET_VARS["srchBy"])) {
                      $focus_form_name = "lookupform";
                      $focus_form_field = "lookupVal";
              } else {
                      $focus_form_name = "newbiblioform";
                      $focus_form_field = "materialCd";
              }

        require_once("../shared/read_settings.php");
        require_once("../functions/inputFuncs.php");
      //  require_once("../shared/logincheck.php");

      Can you spot anything wrong?

      Thanks, John

       
      • Fred LaPlante

        Fred LaPlante - 2005-05-20

        It looks fine to me. 

        Sorry, but I dont recall what your specific problem with Lookup is.  Can you refresh my memory please. 

        Fred LaPlante

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks