lookup patch: yaz error timeout

  • Nobody/Anonymous

    Hi all,
    I'm trying to use lookup patch, but I have some problem :(

    When I search I always have the same error Timeout (10007) [*]

    I've opened port 7090 in my firewall

    I've also tried in lookup_z3950_search.php something like

    //echo "waiting for responses. <br />";
    $test=array("timeout" => 30);

    I'm using ubuntu 7.04  Apache 2.2.3 and PHP 5.2.1

    yaz version 2.1.18 and php/yaz 1.0.7

    looking at phpinfo() it seems to work...

    Any suggestion? ;)


    [*] Very strange...if I search fo isbn I have:

    using host: U.S. Library of Congress
    sending: @attr 1=7 8838461961
    Lookup YAZ Error: Timeout (10007)
    Success! Z39.50 search data is shown below!

    empty array encountered.

    • Fred LaPlante

      Fred LaPlante - 2007-06-07

      I just tried your ISBN (8838461961 ) in the LoC on-line search at http://www.loc.gov/z3950/.  The response is that the ISBN is not recognized. 

      that explains why you search fails, but does not justify the poor display from Lookup.  I will add it to my todo list to provide a more useful response.  Thanks for reporting the problem.

      Fred LaPlante

    • Nobody/Anonymous

      Thank you Fred,

      any ideas for solve the timeout problem?

      Tomorrow I will try with windows+xampp so I could understand if is a firewall problem or a yaz problem (maybe the old version...)

      • Fred LaPlante

        Fred LaPlante - 2007-06-09

        Actually, I beleive there is no time out error.  Rather the program is incorrectly responding to a condition of 'nothing found'.

        Trouble is I am up to my eyes with other work right now and cant give lookup the attention it needs.  I have added the bug to my list and will get to it eventually, but cant say when that will be.  Sorry about that.

        I think a Windows installation will be easier to get running than LINUX, simply because more of the parts are in the download.  Still, the YAZ shipped with XAMPP is not current and will probably not work with Lookup.  You will have to get the latest module from IndexData (or SourceForge).  I find I have to do this with nearly every XAMPP release.


        • Nobody/Anonymous

          Hi Fred I'm sorry to abuse your time again...

          I solve my problem, I just need yaz3 instead of yaz2 (in ubuntu feisty repo).

          Now evrythings works with LoC server.

          I've only one problem with the SBN (italian National Library Service) Z3950 server.

          I think that the problem is the record syntax. SBN uses sutrs. I changed $syntax in lookup.php, but obviously when we have

          $ar = yaz_record($id[$host],$hit,"array");

          nothing will be displayed.

          do you think is a good approach trying to transform sutrs records with ereg_replace or something similar?

          If so, I will take a look :)


          • Fred LaPlante

            Fred LaPlante - 2007-06-11

            I am sorry I can not help you with this question. 

            I do not know anything about 'sutrs'.

            But make any changes you wish to Lookup.

            Fred LaPlante

  • Donald

    Donald - 2010-05-07

    Waow. that really good. you got solution of problem and i am really happy. you try and find the answer and hope you will find out the solution of your upcoming problem during your project or work youself. I am with you and my best wishes with you…. but if you still feel any problem, you can contact me as a friend…

    To keep your interest fast with your mcitp practice exams exam notes questions and answers, we have used a combination method of study.



Cancel  Add attachments

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks