Setting master volume for Nyquist or NyquistIDE?

Help
Hibou57
2013-06-15
2013-06-19
  • Hibou57

    Hibou57 - 2013-06-15

    Hi people,

    Is there a known way to to configure the master volume for Nyquist or NyquistIDE? I got real issues with it, the default is far too loud, so loud that it gives crappy sound.

    The issue seems to remain even if I change the system master volume, sounds from Nyquist are still loud even when the system master volume is very low.

     
    Last edit: Hibou57 2013-06-15
  • Hibou57

    Hibou57 - 2013-06-15

    I found setting *autonorm-target* do the trick. I put this at the start of all SAL file:

    set *autonorm-target* = 0.15
    

    and it's OK, it's now playing with a volume level comparable to that of any other audio applications.

     
  • Roger B. Dannenberg

    There is probably something wrong with your audio setup if the default produces distortion or other problems. Setting autonorm-target to 0.15 just lowers the peaks in your signal to 0.15 of full-scale, using about 13 bits rather than 16. So your problem is not Nyquist, but that your computer cannot play full-scale audio without distortion. (If your sounds start quiet and do not have representative peaks in the first 10 or 20 seconds, autonorm might be the wrong thing for you -- see normalization in the manual.)

     
  • Hibou57

    Hibou57 - 2013-06-19

    Indeed, setting *autonorm-target* is finally not good. The produced WAV file has too little volume with this set to as low as 0.15, it's only OK for playback. Further more, if automatic normalization is off, it does not work any‑more, so that's not reliable.

    May be that's indeed an issue with my audio set‑up. I'm running Ubuntu and ALSA (I could not make it work with Jack). I don't have issue with anything but Nyquist. Will investigate it a future day.

     
    Last edit: Hibou57 2013-06-19

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks