Menu ▾ ▴

#1 ASPNET did not have DBO permission on database

open
nobody
None
5
2005-07-05
2005-07-05
No

Now that I think about it, this bug may not apply, but I'll
finish posting it anyway.

Running NUKEleus 0.1 with DNN 3.1 source zip, the
application failed to create a database for me (using
localhost, trusted connection, and local MSDE server).
Creating the DB by myself, and clicking next, I got an
error that the web app was unable to connect to the
database.

When running with trusted connection, either ASPNET
or the network service must have access to the newly-
created DNN database. In my situation (WinXP Pro +
MSDE) ASPNET had access to the newly created DB
but not DBO permission.

I really like this tool, but it needs to keep pace with the
DNN releases (I'd be willing to help if invited).

Tim

Discussion


Log in to post a comment.