can't start xWindows with dell latitude

NST
Steve_D
2004-11-02
2012-12-05
  • Steve_D

    Steve_D - 2004-11-02

    When I try to run setup_x on my dell latitude ( couple of years old 256mB 700mhz ) I get the following message
    " could not find existing X configuration
    * ddcprobe returned bogus values
    ID:   None
    Name:   None
    HorizSync:   None
    VertSync:   None

    Writing temporary config file to /tmp/@839.0xf86config
    trying to start x server
    Waiting for x server to start
    snip>>>

    xconf.py Fatal IO error 2 (Connection reset by peer) on x server :17.0.
    ERROR: Failed to create /etc/X11/XFconfig "

    Has anyone any ideas on how to get around this?  I've tried booting with the laptop and ide switch and looked at the other boot options but can't see any that would help.  is this an issue with my laptop or am I benid dim?

    any pointers gratefully accepted

    regards

    Steve D

     
    • Paul Blankenbaker

      It would help if we could narrow the scope of the problem. Can you run kudzu on your system and see what video card is reported (and most importantly - is a
      "driver:" reported).

      Here is an example of what to type, and what is reported by my NST development system:

      [root@quesadilla fc2]# kudzu -s -p -c video
      -
      class: VIDEO
      bus: PCI
      detached: 0
      driver: Card:Voodoo3 (generic)
      desc: "3Dfx Interactive, Inc.|Voodoo 3"
      vendorId: 121a
      deviceId: 0005
      subVendorId: 121a
      subDeviceId: 003a
      pciType: 1
      pcidom:    0
      pcibus:  1
      pcidev:  0
      pcifn:  0
      [root@quesadilla fc2]#

      If the "driver:" field is listed as unknown, they you will most likely NOT be able to run X directly.

      Test #2: Make sure X runs indirectly via vnc

      The second test I would like for you to try is to run the "lvnc" command on your NST probe. This should start up a virtual X server and will make sure your system is capable of running X (sans a physical display). Here is the output I see when I run "lvnc" on my old Sager laptop (466Mhz Celeron):

      [root@probe root]# lvnc

      *** Need to start up a font server on this host...
      Starting xfs:                                              [  OK  ]
      *** Starting a vnc server on display: 6
      /usr/local/bin/vncserver :6 -geometry 1000x720 -depth 24 -httpd /mnt/cdrom/local/share/vnc/classes

      New 'X' desktop is probe:6

      Starting applications specified in /root/.vnc/xstartup
      Log file is /root/.vnc/probe:6.log

      *** Xvnc process started:
      root      1583     1  0 08:16 pts/0    00:00:00 Xvnc :6 -desktop X -httpd /usr/share/vnc/classes -auth /root/.Xauthority -geometry 1000x720 -depth 24 -rfbwait 120000 -rfbauth /root/.vnc/passwd -rfbport 5906 -fp unix/:7100 -httpd /mnt/cdrom/local/share/vnc/classes
      [root@probe root]#

      To verify it is working, you will need a second system on the network running the VNC client. We will pretend your laptop running the NST software has IP address 192.168.100.12 for this discussion.

      If your second system is a Linux system, you should be able to bring up the remote desktop by running:

         vncviewer 192.168.100.12:6

      If your second system is a Windows box, you can find VNC client software by looking in the "Windows Utilities" section of the web server your NST probe is running. Point your browser at:

         https://192.168.0.100/

      If you are able to bring up the X desktop remotely, it narrows the problem down to figuring out how to handle your video card/LCD combination.

      Let me know how you make out.

      By the way, we've had a lot more people using X on a NST than we originally anticipated. As a result, we've added a much nicer desktop manager for the upcoming 1.2.0 release.

      Good Luck,
      Paul

       
    • Steve_D

      Steve_D - 2004-11-02

      Paul

      Thanks for getting back so prompltly

      I tried the first suggestion and it came back with the following:

      class: VIDEO
      bus: PCI
      detached: 0
      driver: Card:ATI Rage 128 Mobility
      desc: "ATI| Rage Mobility M3 AGP 2x"
      vendorId: 1002
      deviceId: 4046
      subVendorId: 1028
      subDeviceId: 00b1
      pciType: 1

      I am not in a position to try the vnc out yet but I will get another machine to give it a go as soon as I get the chance.

      Thanks for your time

      Steve D

       
      • Paul Blankenbaker

        Well, that's  a good sign that your driver was not reported as "unknown".

        Let me know if you get the VNC desktop up. If you are successful, could you run the "free" command on your NST probe to see how much memory you have left.

        Here is what my NST probe reports after starting up the VNC server:

        [root@probe root]# free
                     total       used       free     shared    buffers     cached
        Mem:        321228     173408     147820          0      66284      73196
        -/+ buffers/cache:      33928     287300
        Swap:            0          0          0
        [root@probe root]#

        If you happen to have a Linux swap partition somewhere on your hard drive, you can run the "laddswap" command to increase your free space.

        However, you may not want to spend too much time on this problem as we are close to finishing up our next release which has a lot of major changes in regards to bringing up
        X.

        Paul

         
    • Steve_D

      Steve_D - 2004-11-03

      VNC started and I could connect to it but after a while it crashed (I was trying to start snort and acid )  I can wait for the next version and try again.  Thanks for your time

      Regards

      steve D

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks