linefeed / carriage-return not passed to R

  • Eric

    Eric - 2011-06-23

    Hi All,

    My NpptoR recently started misbehaving by not passing a line-feed/carriage-return when a line of command is sent from Npp to R. It used to work fine, but started doing this recently for some reason. For instance, if I have a line "a = 1" in Npp with the cursor on it, hitting F8 will send the command to R but not execute it. If the following line is "b = 2", hitting F8 again will result in "a = 1b = 2" in one single line in R (still not being executed). Also, hitting Ctrl-F8 will send all the lines in the file onto 1 single line in R.

    However, if i *select* some text in Npp (with the mouse), the command is sent to R and then *IS* executed… So in short, I have to manually select each line at a time for the script to be executed properly.

    No idea why that behaviour changed recently. I've tried to fix it by updating to NpptoR 2.5.4 and Notepad++ 5.9, but it still didn't fix the problem (I'm using R 2.9.0 on WinXP Pro SP3). And of course, I've got the option "Append new lines to passed command" ticked in NpptoR…

    This is getting me a bit crazy, so any help welcome… Thanks!

  • Eric

    Eric - 2011-06-23

    OK… I'm progressing! The "bug" seems to depend on the file that's being edited in Notepad++. It doesn't work for a particular .r file, but works for most other .r files I'm dealing with… Beats me as to what forces NpptoR to misbehave with that particular .r file…

  • Eric

    Eric - 2011-06-24

    OK, I worked it out!… For info, It's all because the file was somehow deemed by Npp to be "Macintosh"… I've copied the contents again into a new file from within Npp (which created it with Dow\Windows status) and it all works again.

  • Andrew Redd

    Andrew Redd - 2011-06-24



Log in to post a comment.