Upgraded R & NppToR and cannot pass ...

  • MS2

    MS2 - 2012-10-21

    I have been using NppToR for years and I am so very happy with it. Yesterday, I realized I was long overdue for an R upgrade so I switched from R.2.11 to R.2.15. NppToR could no longer find my Rgui.exe so I uninstalled and reinstalled the latest version of NppToR, too but to no avail. When I install NppToR I receive a message that the Rgui.exe cannot be found so I will have to manually start it but then executions should pass without a problem. However, I have not been able to pass anything, even if I go into the settings and locate the folder where the Rgui.exe is stored. I have tried uninstalling and re-installing everything (R, Notepad++, and NppToR) three times now, including re-installing my previous version of NppToR but still no progress! I will not be forced to copy and paste! Already I miss NppToR and it has only been a few hours. Any advice would be truly appreciated!

  • Andrew Redd

    Andrew Redd - 2012-10-22

    The most common problem for this is that one of the programs is running with different permissions and windows prevents one program from seeing the other.

    Few things to check for.  1. Does npptor pass to Rgui when both are started normally and separately.  2. Will NppToR start R?

    Please give windows version and architecture. when asking for help.  32 bit can have issues sometimes.

  • MS2

    MS2 - 2012-10-22

    No, npptor cannot pass to Rgui when started separately nor can it start R. 64 bit, Windows 7.

  • unvrse

    unvrse - 2012-10-30

    I have been happily using NPP2R for two years on my office desktop without any problems and recently tried to install it on my laptop. I installed R (v2.14.2) without any problem. Then when I try to install NPP2R (v2.6.2), I got an error message during installation: 
    "Error: 0x800401F3 - Invalid class string, Line # --> 460:service :=ComObjCreate("Schedule.Service") Continue running the script?"

    I have 32 bit XP with SP3. When I continue running the script at the end I get the message "NpptoR has been succesfully setup on this computer" but then I cannot pass any comment from Notepad to R (including I cannot spawn R).

    I re-installed R, Notepad++, and NPP2R several times but none help. Could anyone help?

  • Andrew Redd

    Andrew Redd - 2012-11-04

    This sounds like something to do with the COM component interface necessary for the silent passing. Try downloading the standalone binaries and see if they behave any differently.  You can also download and install Autohotkey and run the scripts directly.  If you are technically savvy it is not too difficult to comment out portions that might not be working for you.

    I'm not sure if I still have access to an XP machine to test anymore.
    You might also try an older version of NppToR that might work still, the only problem is that at some point Notepad++ changed menu layouts that messed with NppToR's ability to copy.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks