I can't see the settings menu

  • jon

    jon - 2012-01-26

    I just installed NpptoR, chose the global install and autostart (got the can't find Rgui message).  I can use R, and I can use Npp, but I NpptoR doesn't seem to do anything.  Commands I enter in Npp are not sent to R when I press F8, ctrl+F8, shift+F8, etc.  I tried to look at the settings to see if F8 is really the key I should be using but the only options in the menu for me are Suspend hotkeys, pause script, and exit.  Any idea why this isn't working for me?   I uninstalled, reinstalled, restarted the machine, installed the single user option, downloaded the executable version, and none of them work for me.

    I'm using 32bit Win7, R 2.14.0, Npp, NpptoR 2.6.0

    Thanks in advance for any help!

  • jon

    jon - 2012-01-27

    I see this is a documented bug (ID 3475968), so I assume it has no fix and is not reproducible in your version?

  • Andrew Redd

    Andrew Redd - 2012-01-27

    Correct.  I'm not able to reproduce it, which makes it very difficult to fix.  I notice that you are using 32 bit win7.  I develop in 64 bit, which might account for something.

    I was able to rule out the Notepad++ version.  I updated mine restarted both NppToR and Notepad++ and it worked.

  • jon

    jon - 2012-01-28

    One thing I notice from the 4 or so times I've reinstalled NppToR is that the status bar on the installer doesn't quite finish; it is still about 1/10 of the way from the end when it gives me the spawning R error, and I have to just close the window to finish.  I forget the text that remains in the bottom status indicator, I could post a screenshot if that is helpful.   I also notice that the ini file just says , and no individual user settings are created in the appdata folder.

  • Andrew Redd

    Andrew Redd - 2012-01-29

    I know exactly where it stops.  It is in the part where you install the auto-completion.  That part can be skipped and should work without it as that is the last element of the install.  I will rethink that portion and see if there is an alternative.  The ini file in the install folder should read


    For an install for all users into "C:\program files (x86)".  Otherwise it will be empty, absent, or contain the settings.

  • james olmos

    james olmos - 2012-04-27

    bump..  I have been using Npp toR on my win7 64-bit machine, but this week that server is down so I'm stuck with my winXP 32-bit machine. I seem to have this problem. Any updates? My ini file looks just like yours, halpo.

    Has this issue been solved? Thanks!

  • jon

    jon - 2012-05-30

    I just installed 64bit Win7 on my same laptop and tried to install NPPtoR again, but I still have the same problem.  Back to Tinn-R I guess.  My ini file looks the same too, I posted incorrectly before.

  • Andrew Redd

    Andrew Redd - 2012-05-30

    I'm really sorry that I have not been able to get to patching this.  I think that I might have to make some structural changes, but I have been very busy with work (this does not pay the bills unfortunately).  There are cases that I have been able to reproduce this bug and so there is hope for being able to fix it.

  • jon

    jon - 2012-05-30

    Thanks Halpo; I used NPPtoR in the past and liked it, so I hope you do figure out exactly what is wrong, and I'll load it again in 6 months or so.  I don't think any less of the software just for this hiccup! 

    It isn't the only software that won't work correctly after I re-installed my OS (twice) in the last 12 months.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks