NppToR not saving or cant read notepad++ home

leo silva
  • leo silva

    leo silva - 2011-02-10

    I am using Windows XP, R-2.12.2, notepad++ 5.8.7 ,NppToR 2.5.2 and i dont have admin privileges.

    After the instalation, i used the NppToR -> settings to configure the paths and everything worked.
    If i close NppToR and try to run it again i get an error about the notepad++ directory and i need do configure the path again to make it work.

    I tried this using the NppToR installer and the portable version and i got the same problem.

    Here is my NppToR settings
    R=C:\Documents and Settings\xxxxxxxx\My Documents\R\R-2.12.1
    Npp=C:\Documents and Settings\xxxxxxxx\My Documents\R\Notepad++
    NppConfig=C:\Documents and Settings\xxxxxxxx\My Documents\R\Notepad++

  • Andrew Redd

    Andrew Redd - 2011-02-10

    Disturbing.  Could you post screenshot of the error?  That would help me track it down.  It sounds like the ini file is not being saved.   Could you to check if there is an npptor.ini file in the directory of the portable version.  Let's stick with that since I think that we will be easier to get things working for you.

  • J. Ledvina

    J. Ledvina - 2011-04-24

    I'm having the same problem with the "protable" version of NppToR - it's not portable (it reads and writes to an ini file in %APPDATA%), and it also doesn't remember the path to Notepad++ if I exit and restart NppToR. I've been troubleshooting it and I can confirm the following on 64-bit Windows 7:

    1. The problem occurs whether or not I edit either npptor.ini file (the one in the app directory or the one in the "default data" directory). I did not rename either file.

    2. The "portable" NppToR never writes to either of the ini files, only to the file in %APPDATA%. I always used the "exit" option in the tray menu to exit, in case NppToR is supposed to write to %APPDATA%, then move the files on exit.

    3. If I enter a portable path to my portable Notepad++ (using %Drive%) in the settings dialog, NppToR can launch Notepad++, but if I exit and restart it, it pops up the error referenced above by leprech:

    Error: Failed attempt to launch program or document:
    Action: <\notepad++.exe>
    Params: <>
    The current thread will exit.
    Specifically: The system cannot find the file specified.
    --> 312: Run,%Nppexe%

    After I restart NppToR, the "Notepadd++ Home" box will be blank in the settings dialog, but the path ("%Drive%\path\to\Notepad++\") remains stored in the ini file in %APPDATA%.

    4. If I set the FULL path to Notepad++, NppToR can never launch Notepad++ - it produces the above error message every time.


  • Andrew Redd

    Andrew Redd - 2011-04-27

    I've uploaded version 2.5.3 that should fix this issue among a few other small improvements.  Please let me know if the issue persists or not.  Thanks.

  • J. Ledvina

    J. Ledvina - 2011-04-27

    Unfortunately, your fix did not change the behavior at all. It still doesn't read the ini in %A_ScriptDir% - it saves settings to %APPDATA%, (but it does not save "Notepad++ Home" - it only works until I close the app).

    I have a tiny bit of experience with AHK, so I peeked at the source when I was trying to get it to work over the weekend. If I could compile it (it threw an error about iniGUI.ahk, which isn't included in the source), I would just remove these iniread and if(Global) sections to make my own portable-only executable:

    iniRead, Global, %inifile%, install, global, 0 ;0=false

    Could the problem be your iniread line assigns a value to "Global" whether it exists in the inifile or not, and then your if(Global) statement only checks to see that the variable named "Global" exists? According to the AHK help file, the last value of the iniread line is an optional default value, set if the key doesn't exist in the ini file.

    Should it therefore be:

    iniRead, Global, %inifile%, install, global, 1 ;0=false



    CHEN YU - 2012-03-09

    I am using both portable Notepad++ and portable NpptoR

    which is experiencing the SAME problem.

    I wonder when it would be fixed??

    OS: Windows 7 SP1 x64
    R: 2.14.2 x64

  • Leandro Marino

    Leandro Marino - 2012-04-07


    I'm with the same problem. I have edited the npptor.ini but when i enter in the NppToR settings appears a blank in the Notepad ++ Home. I am attaching the ini file, the settings screen and the error.

    1.  Inifile

    2. Error message

    3. Settings Screen

    OS: Windows 7 x64 (i don't know the service pack)
    R: R2.15.0 installed into the flash drive.

  • Andrew Redd

    Andrew Redd - 2012-09-03

    This should definitely be fixed in 2.6.2.  Please report is if anyone is still having problems.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks