Disable specific internal messages

  • Ede_123

    Ede_123 - 2012-04-27


    there's an option to diable internal messages. The problem is, that this option disables also the output of the executed commands.

    Is there a possibility to disable only some of these messages (e.g. "Process started >>>", "<<< Process finished.", "================ READY ================")? In effect I'd want an output more or less equivalent to what I would get if I ran all commands myself directly on system console.

  • DV

    DV - 2012-04-27

    Can you give examples of commands which output is missed? (The design of the "No internal messages" option seems to remove just "spamming" output which mostly duplicates entered commands.)

  • Ede_123

    Ede_123 - 2012-04-28

    ok, I see the problem…

    I'm using predefined scripts. If I disable internal messages I also disable output of the commands the script executes. Therefore I don't know what the script is currently doing (If the called applications do not produce output themselves)

    What I imagined was that the executed commands are output in the console once so I know what command is currently executed.

  • DV

    DV - 2012-04-29

    Well, from my side, I don't know how much useful would it be to implement different levels of "No internal messages" filtering… :) 
    OK, currently you can use "echo" commands to identify what is going on… E.g. you can add "echo Executing Step1…" right before execution of the first application, then add "echo Executing Step2…" right before the second application and so on. I believe such approach is similar to a .bat file which starts with "@echo off" - the command that has a meaning similar to "No internal messages".

  • DV

    DV - 2012-05-23

    In NppExec v0.4.3, the output of can be temporary disabled via "NPP_CONSOLE -". Thus you can exclude non-desired output. Then via "NPP_CONSOLE +" you can restore the output ability.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks