novelclient doesn't work due to -A option

  • Markus Wuebben

    Markus Wuebben - 2005-05-11

    Hi everyone,
    in my setting, novelclient does not seem to work because
    of the -A option that ncplogin and ncpmap get called with
    from the Novel binary. It results in a strange

    "failed:Get host address `[here is the ip]': Server not found (0x8847)"

    error message. I ran strace on novelclient and saw that
    ncplogin gets called like this:

    write(6, "ncplogin -S [HERE SERVERNAME] -A [HERE SERVER IP] -U \'[HERE USER]\' -P \'[HERE PASS]\'", 67) = 67

    Apparently novelclient (Novel binary to be more precise) writes a tmp file under /tmp from which ncplogin is called in the above described manner.
    Calling ncplogin with these arguments from the command line results in the same error message.

    Now, removing the -A option plus argument and calling ncplogin from the comamnd like this:


    lets me login into the novel server without a problem.
    I encountered the same problem with ncpmap, after I had written a shell script as a wrapper around ncplogin that removes the -A options plus argument and running novelclient again.

    I did not find a hint for what the -A option is good for.
    I am using ncpfs 2.2.6.
    novelclient's latest release (some 0.9.1 or something I guess that is..)

    Why is ncplogin and ncpmap called with -A and would is it good for, I wonder. Do I have some wrong ncpfs installed or such?

    Any help would be highly appreciated...

    PS: By the way: Is the novelclient able to receive those nifty little novel messages? Right now, they are displayed on the console and I find this rather inconvenient! Any hint whether I could use xmessage or such to display those?

    • Ken Conrad

      Ken Conrad - 2005-05-13

      Previously the -A was needed in addition to the -S whenever a tcp connection was being made. The -A specified the host name or address of the server whose ncp name is given as the -S parameter.

      Since you are using 2.2.6 I guess Petr has included new code to find the IP address from the ncp name obviating the need for the -A.

      What can you do about it? See if this helps: go into the location profile setup, advanced settings and find the protocol preference. Change it from IP to IPX and try your login. When using IPX the -A was never needed so maybe the shell command will be formed correctly.

      But it won't append the domain name to your host name so make sure that the server can be resolved by your box using only its hostname. In other words, 'ping server' should work rather than needing to type 'ping'

    • Ken Conrad

      Ken Conrad - 2005-05-13

      P.S. novelclient does not currently have a way to display network broadcasts in a dialog box.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks