Notepad2 installer shuts down Windows XP?!

Samir
2013-09-11
2013-12-10
  • Samir

    Samir - 2013-09-11

    When I run the Notepad2_4.2.25_x86.exe installer, in order to install Notepad2 on an old Windows XP machine, it causes it to shut down and reboot.

    When I double-click on the EXE file I get this prompt.

    Open File - Security Warning

    The publisher could not be verified. Are you sure you want to run this software?

    Name: Notepad2_4.2.25_x86
    Publisher: Unknown Publisher
    Type: Application
    From: C:\Documents and Settings\myname\Desktop

    I click Run. Then I get this prompt.

    Setup Notepad2
    Notepad2 4.2.25
    ©Florian Balmer 2004-2011

    Install Notepad2 and replace Windows Notepad?
    Uninstallation is possible from the Control Panel.

    The time it takes before it unexpectedly shuts down varies. Sometimes this happens instantly, the moment I allow XP to execute this program when prompted to, and right after I see the second dialog box above. I don't even have the time to click the OK button on the second dialog box before it shuts down. Other times, I get past the second dialog box, and I get to click on the OK button, but nothing happens, i.e. no installation progress is shown, no new dialog boxes are shown, as if it's not installing at all. I even have the time to start from the EXE a second time, before the computer is shut down.

    As if there's some process in the background, just waiting to shut down the computer, and this process is started by running the EXE file. If I don't run this EXE file the computer is not shutting down on its own, it operates normally.

    Note that no error message is shown. No Windows error, no application error, no BSOD, nothing... it just shuts down.

    This was the first time ever for me to try installing Notepad2 on any computer. I probably won't be trying to install it anywhere again. I ended up installing the good old Notepad++ (npp.6.4.5.Installer.exe) and it worked like a charm. Actually, Notepad++ is my preferred text editor on Windows. I just thought I would try something new, something lighter, less demanding, something that works well on old tired hardware. It didn't work as expected.

    Any idea why this happens? I am willing to do a diagnosis/analysis if you just tell me what to do. I offer to collect any data that can be useful to you, to help you solve this issue.

     
    Last edit: Samir 2013-09-11
  • Samir

    Samir - 2013-12-10

    Ultimately this issue was caused by a bad RAM memory configuration, i.e. hardware related. It started rebooting even when not running Notepad2. Memtest86+ was also showing errors on the random test. Though it did seem like running Notepad2 somehow triggered the shutdown/reboot more often than it normally would (when not running Notepad2). But once I re-configured the RAM memory the whole problem went away. The Memtest86+ tests also now completed successfully. I had to under-clock the memory.

     
    Last edit: Samir 2013-12-10

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks