No Syntax Highlighting in new document

ALM
2010-07-22
2012-11-14
  • ALM

    ALM - 2010-07-22

    A.  Create a new doc (Ctrl-N).  Write some PHP.  Save it as test.php.  The syntax doesn't get highlighted (like in TextPad for example). 
    B.  Edit the file.  The whole file turns bold black ???????
    C.  Close and re-open, now everything is fine, syntax highlighting shows correctly.

    Also annoyed that code completion kicks in while you're writing comments.  I guess someone might like that.  Parentheses highlighting in comments is also unnecessary in my book.

     
  • DriverOp

    DriverOp - 2010-08-03

    It is posible to restore syntax highlight hitting enter at the end of the first line of the file (no need to reopen the file) but still this behavour is a bug in notepad++.

     
  • starfire

    starfire - 2011-08-02

    no, npp is only for quick edits, dont expect stuff like that from it

     
  • Don HO

    Don HO - 2011-08-03

    Yes, it's possible.

    Just set the language you want in Default language (on the bottom of "New document/Default Directory" tab, in Preferences dialog.

    Don

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks