wie ändert man die kodierung bei UserLang name="..."

2013-03-28
2013-04-06
  • Klaus Lehmann

    Klaus Lehmann - 2013-03-28

    guten tag, bin seit einigen jahren nutzer von notepad++.

    ein kollege hat ein "UserLang" mit dem namen allegro antwickelt. Ich versuche es, etwas besser ;-) zumachen....

    mein problem ist:
    das "UserLang" beginnt so: (aus der Datei userDefineLang.xml)

    NotepadPlus
    UserLang name="flex" ext="flx FLX FLB flb jtp inc" udlVersion="2.1"
    Settings
    Global caseIgnored="no" allowFoldOfComments="no" foldCompact="no" forcePureLC="0" decimalSeparator="0" /
    Prefix Keywords1="yes" Keywords2="yes" Keywords3="no" Keywords4="yes" Keywords5="no" Keywords6="no" Keywords7="no" Keywords8="no" /
    /Settings
    KeywordLists
    Keywords name="Comments" 03/ 04/ 00// 00| 00+- 01 02 /Keywords
    Keywords name="Numbers, prefix1" /Keywords

    frage: wie kann ich im UserLang definieren, wenn so eine datei mit der endung flx usw aufgerufen wird, dann soll die datei in der dos-codierung angezeigt werden (also encoding=852 oder encoding=OEM-852 ?). es geht mir NICHT darum, daß notepad++ alle dateien in dem alten dos-coding öffnet. also NUR diese speziellen dateien mit der speziellen endung sollen geöffnet werden, die in userDefinelang.xml stehen. der rest kann windows/ANSI bleiben ;-)

    einige (dumme) anfängerfragen:
    1. gibt es irgendwo eine dokumentation der schlüsselbegriffe, wie z.b. "encoding=???" geschrieben werden muß?

    1. wie gebe ich den code z.b. aus userDefineLang.xml HIER im hilfeforum wieder? (ich musste oben alle spitzenklammern entfernen...)

    2. weiss jemand warum, es fast unmöglich ist, mehr als 2 GB große xml-dateien zu öffnen? (auf einem 64bit-win7-rechner mit genügend ram). ich muss dafür CRISP, den ehemaligen BRIEF-editor nehmen....., dem ich sehr nachtrauere!!!! aber der service ist eben grottenschlecht geworden! wir reden von einem 200€-editor!!!! also nix für lau! ;-(((((((

     
  • Klaus Lehmann

    Klaus Lehmann - 2013-04-04

    hi fans, wer mir helfen kann, möge mir bitte bitte helfen!
    als belohnung winkt auch eine besichtigung der RADEBERGER brauerei in radeberg! dieses problem, was ich VERSUCHE da oben zu beschreiben, ist mir ein sehr wichtiges!
    danke vielsmals, euer klaus(i)

     
  • Uwe

    Uwe - 2013-04-04

    Hallo Klaus,

    mit dem Kodierungsproblem kann ich dir momentan nicht direkt helfen. Du könntest aber auch ein wenig "tricksen".
    Man kann ja für jede Dateiendung unter Windows ein Programm definieren, mit dem die Dateien
    geöffnet werden sollen. Mach dir doch einfach einen 2.Ordner mit einem seperaten Notepad++, setze deine Kodierung so wie
    du es brauchst, in dem Fall MS-DOS, und wähle dort das NotePad++ aus als Programm zum öffnen der speziellen Dateiendung.
    Rein theoretisch, ich werde das mal heute Abend selbst probieren. ;-)

    Dein Editorproblem, schau dir doch mal den Editor an: http://www.editpadpro.com/ (kostenpflichtig nach Test , ca. 40 Euro) bzw.
    http://www.editpadlite.com/ (frei) an. Mit dem kannst du Dateien > 2 GB öffnen.
    Du kannst auch mit diesem Editor nach Mustern suchen oder RegEx-Syntax benutzen, sofern dir das wichtig ist.

    Viele Grüße
    Uwe

     
  • Klaus Lehmann

    Klaus Lehmann - 2013-04-05

    guten tag uwe,

    wow. genausolche lösungen sind meine! quick and dirty. tolle idee! dass ich selber nicht drauf gekommen bin, es lag so nahe... DANKE! ich mache mich gleich ans testen!

    trotzdem: es "fehlt" die doku zu den begriffen aus der userDefinelang.xml u.ä.
    wer weiss was?

    zu meinem "editorproblem". naja, eigentlich ist es kein problem. mittlerweile weiss ich daß notepad++ große dateien eben nicht kann! gerade getestet: 1,6GB: da sagt notepad++ SOFORT: kann ich nicht öffnen. meine alternative ist CRISP: öffnet den anfang SOFORT, und um ans ende u kommen (strg-ende) dauert es ca 20-30sek.
    danke für den hinweis mit editpadpro! gleich testversion: öffnen sofort, zum ende kommt er nur in 4(!) schritten. ca 4x strg-ende drücken, dann ist er am ende der datei. gefühlt dauert es ähnlich lange wie crisp. der editor sieht jedenfalls GUT aus! scheint auch eine 64bit-fassung zu sein.

    prima. "You made my day"!

    2 stunden später:
    klappt nur mit neuen dateien.
    s.a. config.xml
    New Document default settings :
    format = 0/1/2 -> win/unix/mac
    encoding = 0/1/2/3/4/5 -> ANSI/UCS2Big/UCS2small/UTF8/UTF8-BOM
    defaultLang = 0/1/2/..

            Note 1 : UTF8-BOM -> UTF8 without BOM
            Note 2 : for defaultLang :
                    0 -> L_TXT
                    1 -> L_PHP
                    ... (see source file)
    

    man kann es nur für "New Document default settings" eintragen. himmel....
    die lösung ist troztdem erstmal genial!

     
    Last edit: Klaus Lehmann 2013-04-05

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks