Définir le caractère de fin de ligne CR LF

lacombino
2011-12-19
2012-11-13
  • lacombino

    lacombino - 2011-12-19

    Bonjour,

    Je souhaiterai pouvoir configurer Notepad++ pour que lorsque j'appuie sur Enter, les caractères spéciaux de fin de ligne soit de type LF plutôt que CR+LF actuellement.

    Est ce possible ?

    D'avance merci beaucoup

     
  • Marc Kupper

    Marc Kupper - 2011-12-19

    Cela a été muté en anglais pour https://sourceforge.net/projects/notepad-plus/forums/forum/331754/topic/4892072

    Une réponse a été postée il ya avec l'être répondre:
    19/12/2011 14:52:36 PST
    Allez dans Paramètres / Préférences / Nouveau document (onglet). Réglez le Nouveau document / Format option de "Unix". Cela causera un LF pour chaque <enter> lorsque vous créez de nouveaux fichiers.

    Pour les fichiers existants Notepad + + utilise le format que le fichier existant est. Si le fichier utilise LF alors seulement <enter> va ajouter de LF à ce fichier. Si le fichier utilise CRLF puis <enter> va ajouter CRLF, etc Vous pouvez modifier le format de fin de ligne d'un fichier via Edition / EOL conversion, puis sélectionnez l'un des trois formats disponibles. Si un fichier est déjà Windows, qui est CRLF, alors que cette option sera grisée. Si un fichier est déjà le format Unix, qui est LF, alors que cette option sera grisée. De même, si un fichier existant utilise seulement CR comme sa fin de ligne, puis "Mac" sera grisé.

    Un domaine qui notepad + + ne gère pas bien est mélangé fichiers au format. Par exemple, un fichier a principalement Windows CRLF à la fin de chaque ligne. Une ligne est terminée par un CR. C'est orpheline CR ne sera pas évident. Notepad + + va-leur que c'est un fichier Windows CRLF. Curieusement, les raccourcis clavier par défaut incluent Ctrl-M pour terminer une ligne avec un seul CR (format Mac) mais pas Ctrl-J pour terminer une ligne avec un seul LF (format UNIX).

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks