New Plugin - Customize Toolbar

dave-user
2011-06-05
2013-11-17
<< < 1 2 3 (Page 3 of 3)
  • patmar

    patmar - 2013-05-15

    Hello,

    regarding the TextFX plugin:
    I'm having trouble to add a custom button for "TextFX -> TextFX Insert -> Date & Time - short format". The problem is the "&", I think.

    In oder to at least get the correct display text for this custom button I had to edit the CustomizeToolbar.btn files as follows:

    TextFX,TextFX Insert,Date &&& Time - short format,,custom-icon-2.bmp

    But the button still remains grayed out.

    Any ideas how to get it to work?

     
  • treck

    treck - 2013-05-31

    FamFamFam icons pack converted to CustomizeToolbar format.
    Preview

     
  • Guismeau

    Guismeau - 2013-09-25

    Hello,

    I use Customize Toolbar V3.3
    I try to add new icon from a plugin (XML Tools v2.3.2)
    I wan add "Pretty print (xml only - with line breaks) in my toolbar

    I have enabled 'Custom Bouttons'
    2 new icons appears in my toolbar...

    I have created 'CustomizeToolbar.btn' with :
    Plugins,XML Tools,Pretty print (XML only – with line breaks),,wand.bmp

    but nothing !

    Where the bmp file must be store?
    Can you help me to customize my CustomizeToolbar.btn file?

    Thanks
    Guismeau

     
  • Yaron

    Yaron - 2013-09-25

    The BMP files should be stored in the folder plugins\Config.

     
  • Guismeau

    Guismeau - 2013-09-27

    Thanks for your help.

    the bmp file is stored in plugins\Config

    But, I can't create my button from XML Tools.
    Can you help me to create the command line in CustomizeToolbar.btn ?

    My file is OK?
    Plugins,XML Tools,Pretty print (XML only – with line breaks),,wand.bmp

    Thanks.
    Guismeau

     
  • Yaron

    Yaron - 2013-09-27

    You're welcome.

    Copy and paste the following line:
    Plugins,XML Tools,Pretty print (XML only - with line breaks),,wand.bmp

    You should have used the character "-" (Minus sign).

    Good luck.

     
    • Guismeau

      Guismeau - 2013-10-02

      up

      is there a tuto to add custom button ?

      thank you.

       
  • Guismeau

    Guismeau - 2013-09-30

    nothings better with Minus sign...

    The new bouton must be availble in the customize menu ?

    Thanks.

     
  • Yaron

    Yaron - 2013-10-04

    That line works for me.

    Try to uninstall the 'Customize Toolbar' plugin, and make sure that CustomizeToolbar.dll, CustomizeToolbar.btn and CustomizeToolbar.dat are deleted.

    Reinstall the plugin, edit CustomizeToolbar.btn and look for the desired icon in the Customize Dialog.

     
  • Guismeau

    Guismeau - 2013-10-07

    Thanks,
    It's working fine for me too now.

    The plugin files are in C:\Users\"UserName"\AppData\Roaming\Notepad++\plugins\ The file CustomizeToolbar.btn under \Config\ in the same directory...

    Previously, I had try to update this file in C:\Program Files (x86)\Notepad++\plugins\Config\

    I have discovered that during uninstall process.

    Thank you.
    Guismeau

     
  • Mahmoud

    Mahmoud - 2013-10-08

    Thank you for the great plugin, I have used it to create shortcuts for all my frequently used menu items,

    however I'm not able to make a shortcut for csv lining up menu:
    TextFX,TextFX Edit,Line up multiple lines by (,),,csv.bmp

    perhaps it is because of the comma inside the menu name, but I tried to put double qutoes around this item but it is still not working
    TextFX,TextFX Edit,"Line up multiple lines by (,)",,csv.bmp

     
  • tim hughes

    tim hughes - 2013-10-31

    I too appreciate the great plugin, I used to be a big vi fan, but have seen the light ;)

    I am having difficulty adding a TextFX button for a menu item which has "special" characters. I can add other TextFX buttons for menu items which don't have "special" characters just fine.

    Is there a guide I can RTFM? - I've searched around for examples, and can't seem to find the correct syntax.

    I am trying to add:

    TextFX,TextFX Edit,<red>E:Indent & surround { text lines }</red>,,custom.bmp

    I have tried many different combinations of quotation and escaping both the ampersand and the curly braces; as well as with and without the 'E:'.

    It always shows a disabled icon and an error on the mouseover for the button, presumably because it cannot find the menu item? Any help, direction, suggestion, constructive criticism, etc... etc... etc... is appreciated!

    Thanks - Tim

     
  • spirit

    spirit - 2013-11-14

    Any solutions for above? How can we escape some characters? The plugin is still being developed? I do not see any activity in the subject.

     
    Last edit: spirit 2013-11-14
  • pppoe5

    pppoe5 - 2013-11-17

    Why the default custom button is GRAY? (like the attachment)

     
<< < 1 2 3 (Page 3 of 3)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks