Problem on DBGp 0.6b

2007-11-28
2012-11-14
  • Nobody/Anonymous

    I follow what it said in http://www.ourwikicommunity.com/wiki/How_to_Setup_BDGp_debugger_in_Notepad%2B%2B_to_Debug_PHP

    But I failed using this plugin, I just get some error message like below no matter how I try....
    error:
    ------------------------------------------------------------------------------------
    Unable to map filename: E:\xampp\htdocs\test.php (ip: 127.0.0.1 idekey: A) unix: 0
    ------------------------------------------------------------------------------------

    What I set in the config's file mapping is "127.0.0.1", "", "E:\xampp\htdocs\", "E:\xampp\htdocs\".

    What should I do else to make it work?

     
    • Nobody/Anonymous

      It's ok now. I found that I config the php.ini wrongly.

      The DBGp can now be used. But the error message still show each time notepad++ is restarted, is it normal?
      And A file path in the break point section is changed to a temp file path, and the temp file is opend in notepad++, is it normal too?

       
      • Damjan Cvetko

        Damjan Cvetko - 2007-11-30

        That means that the plugin cannot map the file and does SOURCE retrieval. This is mostly unwanted. Check config that "Use SOURCE" in unchecked.

        Try this settings: "127.0.0.1", "", "E:\xampp\htdocs\", "E:\xampp\htdocs\"

        If it STILL doesn't work, I'll resend the latest build.

        -Zobo

         
      • Nobody/Anonymous

        What was the solution. I am having the same problem.

        Thanks

         
        • Damjan Cvetko

          Damjan Cvetko - 2007-12-21

          If you are using a windows server be sure to use back slashes on both remote and local paths.

          c:\web\    c:\web\

          If you are using a linux server, use slashes on remote and backslashes on local.

          /var/www/  c:\web\

          If you have problems I can try to send you an update.

          -Z

           
    • Damjan Cvetko

      Damjan Cvetko - 2007-11-28

      Hello..
      Please try again, pres DBG button and paster the first few lines here.
      It will help me figure out what's wrong.

      Perhaps it's a windows mapping bug. I have really a hard time testing this. No windows server.

      In the mean time, you can try to enable SOURCE in config. if that works. But you will not be able to edit files this way.

      Best regards.
      -Zobo

       
    • Nobody/Anonymous

      When Remote & Local Path are set to "E:\xampp\htdocs\", no error message is shown and also nothing happened
      -------------------------------------------------------------------------------------------------------
      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="6584"><engine version="2.0.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
      Send: feature_set -i 1 -n max_depth -v 3
      Send: feature_set -i 2 -n max_children -v 15
      Send: breakpoint_set -i 3 -t line -f file:///E:\xampp\htdocs\test.php -n 2 -s enabled -h 0 -o >=
      Send: breakpoint_set -i 4 -t line -f file:///E:\xampp\htdocs\test.php -n 4 -s enabled -h 0 -o >=
      Send: breakpoint_list -i 5
      Send: step_into -i 6
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="1" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_children" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="3" state="enabled" id="65840001"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" state="enabled" id="65840002"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="5"><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="4" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="65840002"></breakpoint><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="2" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="65840001"></breakpoint></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="6" status="stopped" reason="ok"></response>
      Send: run -i 7
      ----
      Disconnect: 127.0.0.1
      ------------------------------------------------------------------------------------------------------

       
      • Damjan Cvetko

        Damjan Cvetko - 2007-11-28

        Ok.. This is strange to hell and back!

        I see this: fileuri="file:///E:/xampp/htdocs/test.php"
        But I could swear that it used to be  file://E:\x...

        I need to look at the code. I can do that when I get home in about 3-4 hours. I'll post what find out. Send me a mail, so I can send you a changed .dll to see if it works.
        I'm currently debugging code with no problems.

        Btw: Don, thank you for Base64 plugin :D

        -Zobo

         
        • Damjan Cvetko

          Damjan Cvetko - 2007-11-29

          I had time to look at it and I set up PHP5 w/ XDebug 2.0.2 (for PHP 5.2.1-5.2.7).
          I only did a test with the CLI, but it was obvious that encoding in DBGP changed. Probably somewhere around XDebug 2.0.0

          I have a fixed version and will release as I can. If anyone needs it right away, drop me a mail.

          RE,
          -Zobo

           
    • Nobody/Anonymous

      When Remote & Local Path are set to "E:/xampp/htdocs/", error message is shown, and break point is reset:
      ------------------------------------------------------------------------------------------------------ 
      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="6584"><engine version="2.0.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD8NCmZvciAoJGk9MDskaTwxMDskaSsrKQ0Kew0KCWVjaG8gJGkuIjxicj4iOw0KfQ0KPz4NCg==]]></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      ----
      Send: breakpoint_list -i 4
      Send: step_into -i 5
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="4"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="5" status="stopped" reason="ok"></response>
      Send: run -i 6
      ----
      Disconnect: 127.0.0.1
      ------------------------------------------------------------------------------------------------------ 

       
      • Damjan Cvetko

        Damjan Cvetko - 2007-11-28

        Btw, try to set:
        LOCAL:   E:\xampp\htdocs\ REMOTE:  E:/xampp/htdocs/

        Best.

         
    • Nobody/Anonymous

      Just tested with the version 0.0.7.11 you sent me with path "E:\xampp\htdocs\&quot;, but same as before, nothing happened:
      ----------------------------------------------------------------------------------------------------
      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="3516"><engine version="2.0.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
      Send: feature_set -i 1 -n max_depth -v 3
      Send: feature_set -i 2 -n max_children -v 15
      Send: breakpoint_set -i 3 -t line -f file:///E:/xampp/htdocs/test.php -n 2 -s enabled -h 0 -o >=
      Send: breakpoint_set -i 4 -t line -f file:///E:/xampp/htdocs/test.php -n 4 -s enabled -h 0 -o >=
      Send: breakpoint_list -i 5
      Send: step_into -i 6
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="1" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_children" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="3" state="enabled" id="35160001"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" state="enabled" id="35160002"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="5"><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="2" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="35160001"></breakpoint><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="4" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="35160002"></breakpoint></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="6" status="stopped" reason="ok"></response>
      Send: run -i 7
      ----
      Disconnect: 127.0.0.1
      ----------------------------------------------------------------------------------------------------

       
    • Nobody/Anonymous

      also tried LOCAL: E:\xampp\htdocs\, REMOTE: E:/xampp/htdocs/, still nothing happened:
      ----------------------------------------------------------------------------------------------------
      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="3516" idekey="A"><engine version="2.0.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Send: breakpoint_set -i 4 -t line -f file:///E:/xampp/htdocs/test.php -n 2 -s enabled -h 0 -o >=
      Send: breakpoint_set -i 5 -t line -f file:///E:/xampp/htdocs/test.php -n 4 -s enabled -h 0 -o >=
      Send: breakpoint_list -i 6
      Send: step_into -i 7
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD8NCmZvciAoJGk9MDskaTwxMDskaSsrKQ0Kew0KCWVjaG8gJGkuIjxicj4iOw0KfQ0KPz4NCg==]]></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" state="enabled" id="35160005"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="5" state="enabled" id="35160006"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="6"><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="2" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="35160005"></breakpoint><breakpoint type="line" filename="file:///E:/xampp/htdocs/test.php" lineno="4" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="35160006"></breakpoint></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="7" status="stopped" reason="ok"></response>
      Send: run -i 8
      ----
      Disconnect: 127.0.0.1

       
    • Nobody/Anonymous

      Just like before, Remote & Local Path are set to "E:/xampp/htdocs/", error message is shown, and break point is reset:
      ----------------------------------------------------------------------------------------------------
      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="3516"><engine version="2.0.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD8NCmZvciAoJGk9MDskaTwxMDskaSsrKQ0Kew0KCWVjaG8gJGkuIjxicj4iOw0KfQ0KPz4NCg==]]></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      ----
      Send: breakpoint_list -i 4
      Send: step_into -i 5
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="4"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="5" status="stopped" reason="ok"></response>
      Send: run -i 6
      ----
      Disconnect: 127.0.0.1

       
      • Damjan Cvetko

        Damjan Cvetko - 2007-11-29

        Crap and double crap...
        This works for me:

        server: 127.0.0.1
        id:
        remote path:  e:\ local path:  e:\

        Re
        -Zobo

         
    • Nobody/Anonymous

      Just tried again, don't know why its ok now, no more error message & temp file.
      Thanks for your plugin and also your help!

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks