Having trouble with securepad

  • Max

    Max - 2013-12-02

    Hi , for some reason with the new version of Notepad++ securepad with not update and says 'failed to install' , then if I download the dll and put it in the folder and try to encrypt a 'exception' happens , but I notice the dll is version 2.1 and cant find a 2.2 .

    Any ideas? , its not for critical stuff , just in case there are snoopers about that all , and btw nppcrypt blowfish if I save a good text file then decrypt it half of it is gobblydagook ?

    tia ..

  • Max

    Max - 2013-12-03

    I would not have a clue on what happened , but today I went to check securepad it worked fine ??

    Something to do with self registering the dll in win7-64 maybe?

  • David Invenio

    David Invenio - 2013-12-04

    I have experienced the same problems with both nppCrypt and SecurePad - except mine has not started working.

    Have you found any other information about these two plugins?

    Using nppCrypt was very frustrating to see small bits of the document still encrypted, or garbled. But SecurePad wouldn't even install, and when I put the dll in the plugins folder manually I got all manner of errors about it not being a valid plugin.
    Very frustrating.

  • Max

    Max - 2013-12-05

    Hi , no I would not have a clue on why it started working (securepad) , I'm just glad it has!

    I went through heaps of sessions to try to get it to work , uninstall/reload dll try different ones but only 1 time did it say "this dll is incorrect version" and I think that was after a restart and open up np++ , I like securepad as I'm lazy and its simple with the one box for password , nppcrypt has that multiple choice and sometimes I might forget which one I used so I do not use it at all , but also that issue with some bits still gobbledygook with the first choice blowfish I think .

    Btw , np++ will still not find a dll on the update and install it , so this time again I manually installed it and it did not work again so just left the dll in as above 2 posts, it must have been a day or so later when I thought I would give it a go again and IT WORKED , but dunno why ..

    Any idea on why it says the dll is version 2.1 in the properties? , its supposed to be a version 2.2 ..

    I like NotePad++ , I use it a lot and now I can still use securepad which I like for the above reasons .

    edit> I just thought , maybe run as admin for np++ as I just noticed it loads straight away without the "do you want to run this program" thing , that's one thing I never tried , run as admin "then" try to install the dll ?

    Last edit: Max 2013-12-05
  • Dominic Tobias

    Dominic Tobias - 2013-12-06

    Hi I am the author of SecurePad. I recently received an email saying it no longer works. Unfortunately I use Linux and OS X now day to day but I have a Virtual Machine setup with Windows 8 64bit now and I recompiled the plugin with the latest plugin files from Notepad++ and this fixed the issues for me on Notepad++ 6.5.1.

    You can find 2.2 over here: https://github.com/DominicTobias/SecurePad
    Please download the 2.2 DLL from here and do a manual install and let me know if you still have issues: https://github.com/DominicTobias/SecurePad/tree/master/bin

    If it is working then I know that there is an issue with the download provided by the Plugin Manager.

    If you do have issues with that DLL let me know what version of Notepad++ and Windows and 32 or 64bit thanks.

  • Max

    Max - 2013-12-07

    Hi Dominic , for the others click "raw" on the link page and it'll download :-) , securepad has already started working for me as posted previously and still now is fortunately , but I downloaded the one in your link , removed the dll in np++ and started it , then closed np++ and placed the above dll in the plugin folder and restarted np++ and decrypted a file and then encrypted another no trouble fyi ..win7-64

    Please I'm not complaining but another confusion is that the dll just downloaded , if one looks at the file properties then the details tab it still says version 2.1 , there was one once ages ago (like 6months? maybe longer) that did say 2.2 I seem to recall?
    cheers ..

  • Max

    Max - 2013-12-29

    Securepad is still working ok btw , also I noticed this is in the wrong area as I came straight here , I never saw the face page with the "help" area ....

    So last post here but before I go , if one has crlf in bold at the end of every line go to view then show symbol and unpick "show all characters" crlf is carriage return line feed from the old days , I do not recall enabling it though? :-) , at first I thought securepad was busted again ..

  • Dominic Tobias

    Dominic Tobias - 2014-01-28

    Thanks for the info Max. I must have forgotten to change it in the resource file of the project. I'll have to try and remember to edit it when I am next on Windows (might be a while unless someone else wants to do it as it is opensource now)


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks