Problem with build NppPlugin.NET : "cannot find the specified file"

  • treck

    treck - 2013-08-19

    I would like write plugin for N++ in C#. (that would embed xulrunner in n++ dockable window - e.g. for html/xul live preview) However I have problems with compiling sample NppPlugin.NET. (I'm new in C#, .NET, C# IDEs though)

    When I try build NppPlugin.NET v0.6 demo in SharpDevelop 4.3 using NppManagedPluginDemo.VS2010.sln. I try following steps

    1. In file NppPluginNETHelper.cs I have error with unrecognized name Point. So I've added line using System.Drawing; as last using statement.
    2. Next I receive Cannot find lib.exe in '*Undefined*\..\VC\bin'. error in NppPlugin.DllExport.targets. So I tried replace in the file $(DevEnvDir) to E:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE --> but then I receive E:\Piotrek\Temp\NppPlugin.NET.v0.6\Demo\NppManagedPluginDemo\DllExport\NppPlugin.DllExport.targets(8,5) : Error : Nie można odnaleźć określonego pliku (eng: "Cannot find specified file")

    When I installed template using instruction in NppPlugin.NET.v0.6\Templates\SharpDevelop 4.x\HOW-TO-INSTALL.txt I receive the same error:
    Error : Nie można odnaleźć określonego pliku (eng: "Cannot find specified file")

    However Sharpdevelop works in general with built-in project templates.

    When I'm trying build NppManagedPluginDemo.VS2010.sln in Visual Studio 2012 after adding using System.Drawing; error is similar:

    1>------ Build started: Project: NppManagedPluginDemo.VS2010, Configuration: Debug Any CPU ------
    1>  NppManagedPluginDemo.VS2010 -> C:\Users\Piotrek\Desktop\NppPlugin.NET.v0.6\Demo\NppManagedPluginDemo\bin\Debug\Demo.dll
    1>  ILDasm: calling 'ildasm.exe' with /quoteallnames /unicode /nobar /linenum "/out:C:\Users\Piotrek\AppData\Local\Temp\tmp9A39\" "C:\Users\Piotrek\Desktop\NppPlugin.NET.v0.6\Demo\NppManagedPluginDemo\bin\Debug\Demo.dll"
    1>C:\Users\Piotrek\Desktop\NppPlugin.NET.v0.6\Demo\NppManagedPluginDemo\DllExport\NppPlugin.DllExport.targets(8,5): error : Nie można odnaleźć określonego pliku
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

    Any ideas?

    Windows 7 x64, Visual Studio 2012 installed in non system (C:) partition (on E:) if it matters

    Last edit: treck 2013-08-19
  • treck

    treck - 2013-08-20

    OK, So I worked around this issue by installing Visual C# 2010 Express. I also replaced "$(DevEnvDir)" in NppPlugin.DllExport.targets to "E:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE" (VS 2010 directory) because Visual had problem with finding "lib.exe". Now demo works well.

    Last edit: treck 2013-08-20

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks