Cannot get .json to show as javascript

Andrew K
2014-04-09
2014-05-17
  • Andrew K

    Andrew K - 2014-04-09

    Trying to get JSON files with *.json extension to show up in javascript format. Have tried going thru Settings>Style Configurator>Javascript and set the user ext. I've also tried modifying langs.model.xml and stylers.model.xml to add json in the ext= tag. and nothing seems to work. I reboot, open a *.json file and its not formatted.

    This is what's in langs.model.xml

    < Language name="javascript" ext="js json" commentLine="//" commentStart="/" commentEnd="/" >

    This is what's in stylers.model.xml

    < LexerType name="javascript" desc="Javascript" ext="js json" >

    Running version 6.5.5 (UNICODE) on win7pro

    Thanks.

     
  • cchris

    cchris - 2014-05-17

    The .model versions are factpry defaults used when loading the current configuration fails. So changing them is not expected to do much.

    In Settings -> Styler Configurator, simply select Javascript and then, in the "User ext." field, add "json".

    CChris

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks