No "Notepad++" in right click menu

2005-07-18
2012-11-13
  • Nobody/Anonymous

    I did not have that option when I installed version 3.1, that option was there in version 3.0. I found that context menu entry quite useful since it not for any file type in particular so it appears whatever the file type is so you can just right click on any file and open it with notepad++. But I can't get that menu entry for version 3.1

     
    • Nobody/Anonymous

      Hello,

      This tip runs perfectly for me (W2000 SP4). Thanks a lot.

       
    • Nobody/Anonymous

      1. Create a new document and insert the following

      REGEDIT4

      [HKEY_CLASSES_ROOT\*\Shell\Notepad++]

      [HKEY_CLASSES_ROOT\*\Shell\Notepad++\Command]
      @="\"C:\\TOOLS\\Notepad++\\notepad++.exe\" %1"

      2. In the path, replace C:\\TOOLS with the path of where your Notepad++ lives.
      3. Save the file as a .REG file and then run it to register.

      Another tip

      I also like to have my shortcuts handy so I created a batch file that inserts a shortcut into the start menu and quick launch bar. The batch contents are as follows.

      Copy "NOTEPAD++.lnk" "%USERPROFILE%\Application Data\Microsoft\Internet Explorer\Quick Launch"
      Copy "NOTEPAD++.lnk" "%ALLUSERSPROFILE%\Start Menu"

      The batch file assumes that a shortcut "NOTEPAD++"  exists in the same folder as where the batch file is being run from.

       
    • Nobody/Anonymous

      This may provide not provide the same functionality, but you can also just put a shortcut to Notepad++ (including command line args, if you want) in C:\Documents and Settings\<username>\SendTo

      -Gavin

       
    • Nobody/Anonymous

      Got the context menu handler, but... when trying to direct .vbs or .cmd files to it, it seems to try and execute the code instead of passing it to NotePad++?  MS AntiSpyware kicks in as if a script is trying to run & if I "Allow" it - it does attempt to execute.  Checked the Registry & registry setting is correct.

      Clues?

       
    • HomieHome

      HomieHome - 2005-07-18

      yip - i need the same thing very urgent...

       
    • Don HO

      Don HO - 2005-07-19

      Due to the numerous file association bugs because of the context menu entry, this feature is not supported anymore by Notepad++ installer.

      However, you can add this entry in the registry manually to make notepad++ context menu entry work :

      1. add a key named "Notepad++"
          in the key HKEY_CLASSES_ROOT\*\shell

      2. add a key named "Command" in the key "Notepad++"

      3. modify the default string in the key "Command", by double clicking,  as "D:\WinAppz\notepad++\notepad++.exe" "%1"

      No need to say all the blabla about "backup your registry before you modify it" and "do your own risk".

      Don

       
      • Jason Brinkle

        Jason Brinkle - 2005-07-28

        Works for me.

        WinXP SP2
        Notepad++ 3.1

        Thanks nobody!

         
    • Nobody/Anonymous

      This did not work on my computer.

      Windows XP SP2

      .....Chris Moorhead
      chris.moorhead@tticd.com

       
    • Nobody/Anonymous

      Yes...

      I did make sure
      "D:\WinAppz\notepad++\notepad++.exe" "%1"

      actually points to the installed folder which in my case is
      "C:\program files\notepad++\notepad++.exe" "%1"

      .....Chris

       
      • Don HO

        Don HO - 2005-07-19

        Yes, of course, you should replace the path by yours.
        I didn't state precisely.

        Don

         
    • Nobody/Anonymous

      hm .. dosnt work for me with winxp sp2

      there isnt a "HKEY_CLASSES_ROOT\*\shell" key, did you mean the "HKEY_CLASSES_ROOT\*\shellex" key?

      When i do it in "HKEY_CLASSES_ROOT\*\shellex" it dosnt work.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks