Have trouble getting Japanese text to show up

2013-02-03
2013-02-18
  • Deborah Clark

    Deborah Clark - 2013-02-03

    I've looked at all the help sites on this program I can find and nothing works. It either shows up as little rectangles (when UTF-8) or question marks (when almost anything else). And the one help page I thought I found that would actually help me was deleted off of its page. (gave me a 404 when I clicked the "Read More" link at the bottom. Does anyone have any idea how I can fix this? I do kind of need this to work.

     
  • cchris

    cchris - 2013-02-03

    1/ Use an encoding that matches your existing file (if the problem is reading an existing file). I'm aware of at least UTF-8, UCS-2 LE and Shift-JIS, there could be more.

    2/ Does the font you are using support Japanese glyphs?

    If none of this helps, and you can enter the characters in other applications, then please come back with OS version and locale.

    I just performed the following experiment. Using BabelMap, I copied a few ideograms 'not sure they are specifically japanese), opened N++ 6.2.3 and pasted in an UTF-8 document. I got the shapes I expected to see. Win 8/64 fr_FR . I happen to use the Consolas font as text default.

    CChris

     
    Last edit: cchris 2013-02-03
    • Deborah Clark

      Deborah Clark - 2013-02-06

      i was trying to copy paste japanese text from a web page to n++, and i don't know what you mean about fonts. i don't see any font option on n++ (and if you are talking about in general, i do have a japanese font installed on my computer...

       
  • cchris

    cchris - 2013-02-09

    There are font options. Go to Settings -> Style Configurator, Global styles, Default style, and set your font to this japanese font you have installed. Now try again...

    CChris

     
  • Deborah Clark

    Deborah Clark - 2013-02-13

    argh, it's still not working for me. i can get the japanese text to show up in word, but not in notepad++

     
  • cchris

    cchris - 2013-02-18

    Can you email a sample file to quasar850 hat rediffmail doubt com ? (obvious antispam protection there). Perhaps I can sort out the font/encoding problem.
    I assume you changed font for default text as suggested.

    CChris

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks