spell checker plugin not working

Techwriter
2012-01-16
2012-11-28
  • Techwriter

    Techwriter - 2012-01-16

    I have Notepad++ v. 5.9.6.2 installed on a Dell Latitude E6520 with i5 processor, 8 GB RAM, Win 7 Pro 64 bit SP 1.

    I have Aspell v. 0-50-3-3 installed.  I have SpellChecker.dll located in C:/Program Files (x86)\Notepad++\plugins.  Spell Checker shows up in the list of plugins.

    Despite this, when I tried to run spell checker, I received this message:

    GNU Aspell and/or dictionaries are missing . . . .  If Aspell is already installed, do correction of relative path to aspell-15 and restart.

    So I entered c:\program files (x86)\aspell\bin\aspell-15.dll and restarted.

    I get the same message, but I also get the Spell-Checker window (behind the error message window).  I can move the error message window to get access to the spell checker window, but  it is not usable - none of the buttons work.

    I searched this forum, but, as far as I can tell, I have done everything the threads say to do for this problem.  Can anyone help?

     
  • Dave Brotherstone

    "relative" is the keyword, and not including the aspell-15.dll, so for you it should be the default:

    ..\Aspell\bin
    

    Hope that helps.
    Dave.

     
  • Techwriter

    Techwriter - 2012-01-17

    I changed the path because the spell checker didn't work with the default path as you described.

    Any ideas?

     
  • Techwriter

    Techwriter - 2012-01-20

    I still need help please.

    I have tried a variety of path statements to get the spell checker to work, all without success.  The default ..\Aspell\bin does not work.

    Can anyone help?

    Thank you

     
  • Vera

    Vera - 2012-01-21

    Hi,
    as you're on Win7 I'd suggest to install Aspell outside of any system-folder into its own folder (so it's allowed to write in it) like e.g.: C:\Aspell

    When installing Aspell do not miss to install at least 1 dictionary as well (important!) ( http://aspell.net/win32/ )

    (maybe you should reboot once after an un- and new installation)

    In case NPP/plugin still doesn't find Aspell by its original setting you'd need to enhance the relative path to Aspell by one level (according to my example):  ..\..\Aspell\bin

    good success

     
    • Church

      Church - 2012-11-28

      I too had the issue mentioned at the top with Windows 7. Vera's solution for installing Aspell outside of a system-folder worked for me. I installed it to C:\Aspell

      Thank you.

       
  • shutterbug35mmd

    shutterbug35mmd - 2012-05-30

    I hope you had resolved your problem.

    The solution is to ADD AT LEAST ONE ASPELL DICTIONARY to your system and put it in the same ASPELL directory. Note that the dictionary installer would add ASPELL after the directory specified, so double-check.