Missing MSVCR80.dll ?

2008-11-12
2012-11-13
1 2 > >> (Page 1 of 2)
  • Robin Smidsrød

    Robin Smidsrød - 2008-11-12

    I just updated my Notepad++ to the latest version (5.1.1) because I kept getting this dialog box before the application starts.

    "Notepad++.exe - Unable to Locate Component"

    "This application has failed to start because MSVCR80.dll was not found. Re-installing the application may fix this problem."

    The message seems to be just an annoyance, because the application works as expected after I click the OK button.

    How can I get rid of the message?

     
    • Harry

      Harry - 2008-11-12

      One of the plugins is triggering that message, could you try removing one by one and see which one it is? Its usually an incorrect build setting

       
  • kas

    kas - 2010-04-20

    Me too. This is so annoying that I think I will change from notepad++ to metapad … I should never have updated. It was just fine before that…

     
  • kas

    kas - 2010-04-20

    I have no plugins..

     
  • cchris

    cchris - 2010-04-20

    Really? To be sure, simply rename your plugins folder, and restart Notepad++. Then you won't have any plugin, and please tell us whether ou are still missing Msvcrt80.dll

    CChris

     
  • kas

    kas - 2010-04-20

    After an hour I said screw it and uninstalled it. Found the dll online and put it in the Windows folder. Then reinstalled the program and now it works.

     
  • gwg

    gwg - 2010-06-09

    I renamed the plugins folder as suggested in 5. and the problem went away.  I haven't installed any plugins personally so it must be something bundled with Notepad++ causing this.

     
  • Dave Brotherstone

    Just as a shot in the dark, can you try with the plugins back, and only remove TextFx (NppTextFX.dll).  I have a hunch that's the offender.

    A rebuild of TextFX with some bugs fixed is on my list, but it's a way down at the moment - I suspect it's on other peoples lists too.

    Dave.

     
  • gwg

    gwg - 2010-06-09

    Yep, that's it, renamed plugins back confirmed error, renamed NppTextFX.dll and error goes away.

     
  • Peter Scheidegger

    Hello together,
    I had the same problem. Will it be fixed in a future release?
    I think recompiling the "NppTextFX.dll" should fix this problem.
    Kind regards
    Peter

     
  • Don HO

    Don HO - 2010-07-19

    @pscheid and greatwebguy
    What is your Notepad++ version? and TextFX version?
    Does your TextFX come with Notepad++ release or you update it yourself?

    Don

     
  • nickbick

    nickbick - 2010-08-07

    yeah, i did it and no errormsg occurred anymore. but: i don't have any plugins now :-)

    after some times of using, notepad++ suddenly starts to inform me about the missing msvcr80.dll. i think that was directly after i was associating this editor with a new filetypes (*.log). after that, this error msg is threating me :-)

    and now? somebody any idea?

     
  • nickbick

    nickbick - 2010-08-07

    can't edit my last post, and i was'nt able to see all the other posts before i wrote that so:

    windows 7, notepad++ v5.7 with all standard plugins. as i mentioned: after i was associating this editor with a new filetypes (*.log), this error occurred but after clicking "ok", everything works fine.

     
  • nickbick

    nickbick - 2010-08-07

    renaming alle the DLLs does not work, i have to rename the plugin folder oder delete all dlls to get out of the msvcr80 terror :-)

     
  • cchris

    cchris - 2010-08-08

    2010-08-07 16:29:28 GMT
    From your account, the problem relates to TextFX. Can you download http://oedoc.free.fr/NppTextFXforv57.dll , and see if it make any difference?

    CChris

     
  • nickbick

    nickbick - 2010-08-08

    no, sorry. once there is any (also the downloaeded) dll file in the plugins folder i will get the message!

     
  • Patrick Bieser

    Patrick Bieser - 2010-10-24

    I downloaded the new NppTextFXforv57.dll, but I am still getting the same MSVCR80.dll error.  Any other suggestions?

     
  • Patrick Bieser

    Patrick Bieser - 2010-10-24

    Clarification:  I downloaded the new NppTextFXforv57.dll, but I am still getting the same MSVCR80.dll error.  More verbose:  I put the dll in the plugins folder and renamed the original file from the install.  Same error.  Renamed NppTextFXforv57.dll to NppTextFX.dll.  Same error.  Put a copy of MSVCR80.dll in the C:\windows\ folder.  Different error.  Removed the file altogether and the error goes away.

     
  • maxmula

    maxmula - 2011-01-26

    Hi there,
    I'm using NPP v.5.8.6 and the problem is still present.

    The TextFX Characters plugin seems to be the one buggy (removed it, all was fine, reinstalled it and the error was there) but apparently its functions are working when recalled… o.O

    Any news on bugfix?

    Best regards,
    MAx - Italy

     
  • franz1303

    franz1303 - 2011-10-27

    Hi!

    I was still having the same problem with the latest version on NPP (5.9.5)… I've analysed the plugins and some of them are indeed causing troubles… I've tested my installed plugins and here are the ones you could remove to avoid getting this annoying dll error message:

    - ComparePlugin.dll (version 1.5.5.0)
    - mimeTools.dll (version 1.6.0.0)
    - NppConverter.dll (version 3.0.0.0)
    - NppExport.dll (version 0.2.8.0)
    - NppFTP.dll (version 0.2.4.0)
    - NppTextFX.dll (0.2.6.0)
    - SpellChecker.dll (version 1.3.3.0)
    - XMLTools.dll (1.0.0.1)

    There are maybe other ones but I've not installed all existing plugins.

    Concerning the trick of copying the MSVCR80.dll to the running directory or the SYSTEM32 folder is solving the issue… But brings other runtimes issues.

    I hope this helps :-)

    Best regards,
    Fränz

     
  • Ultimate

    Ultimate - 2011-11-09

    Hi everyone.
    I just copied the file MSVCR80.dll to the plugins directory, plugin finds it & everything is smooth.
    The file comes with nearly every software distribution that requires it, except this plugin. I just let windows 7 indexer (click windows orb and start typing) search for the file and found about 10 copies. Copied over the one from OpenOffice.

     
  • Vera

    Vera - 2011-11-10

    @ultimateevil

    great tip ~ thanks :-)

     
  • ohadhawk

    ohadhawk - 2012-01-02

    Can someone please upload this specific file  either to this thread or to some file sharing site ?
    Thanks !

     
  • Loreia2

    Loreia2 - 2012-01-02

    Hi,

    just search your C:\Program Files\ directory and you will find it.
    For example, I found one in C:\Program Files\Mozilla Firefox directory.

    Or search with Google, this was the first result I got:
    http://www.dll-files.com/dllindex/dll-files.shtml?msvcr80
    (click "Download zip-file" and you will get it.)

    BR
    Loreia

     
  • ohadhawk

    ohadhawk - 2012-01-02

    Sorry, I should have specified that I had already tried all the msvcr80.dll on my computer (about 20) and this one as well.
    I still get an "R6034 An application has made an attempt to load the C run time library incorrectly."

    Probably it's the wrong version.
    Can someone still send the dll that worked from openOffice ?

     
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks