File Association/"Open With" Notepad++?

2008-08-24
2012-11-13
  • Michael Collier

    Michael Collier - 2008-08-24

    i expect this has been asked before, and i apologize, but i am not a sophisticated sourceforge user, and i don't see any sort of forum search capability here that will let me narrow a search down. a more general search of sourceforge and the web at large did not turn up anything.

    my recent Notepad++ 5.0.3 installation does not remember file association settings from session to session (Notepad++->Settings->Preferences->File Association), nor will Windows Vista Ultimate SP1 (64-bit) permit me to associate Notepad++ with any sort of file extensions, not even for .TXT files. i can browse to the Notepad++.exe and select it, but that is as far as Windows will take it... Notepad++ is not then included in the list of applications that can open the file, or etc.

    attempting to fiddle with compatibility settings for Notepad++.exe results in a "core dump" (i.e. "The application has stopped working...") upon ant attempt to access the settings dialog (Notepad++->Settings->Preferences).

    i did not have these sorts of difficulties using Notepad++ v4.x. i have seen tutorials on the web discussing how to overwrite the native Windows Wordpad application with Notepad++, but that seems unnecessarily invasive.

    are there other workarounds? thanks.

     
    • Robert Wishlaw

      Robert Wishlaw - 2008-08-25

      Change the name of notepad++.exe to npp.exe. This worked for me on Vista Ultimate x64.

       
      • OsakaWebbie

        OsakaWebbie - 2008-08-31

        Two questions from a 3rd party observer of this thread who happens to have the same problem:

        (1) Do you just change the name of the main program file (and any shortcuts you have made), or do you have to do something else, like in the registry or something?

        (2) Does anyone know if this fix would work on Windows XP also?

         
    • Michael Collier

      Michael Collier - 2008-08-31

      yep, worked like a charm. notepad is now embedded in Windows Vista's "Open With" menu, and etc.

      i guess this would be a "bug" in the installation?

      anyway, thanks very much.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks