Notepad++ only starts up in Admin mode

Andy
2014-03-21
2014-03-21
  • Andy

    Andy - 2014-03-21

    I have been trying to install Notepad++ v6.5.5 on a new computer running Windows 7.

    1. It only installs if I run the installer in Admin mode.
    2. If I runs the installer in normal mode, it will complain about not being able to write files, starting with "Error opening file for writing: C:\Program Files\Notepad++\SciLexer.dll". When the installation finishes, there is no directory called "C:\Program Files\Notepad++"! I am not able to even start the application and "Control Panel -> Programs -> Programs and Features" does not think Notepad++ is installed.
    3. After installation by running the installer in Admin mode, if I try to start it from the Start menu, then a warning message pops up "Do you want to allow the following program from an unknown publisher to make changes to this computer?". If I click no, Notepad++ is not started. If I click yes, then Notepad starts in Admin mode (the title of the window says "... Notepad++ [Administrator]").

    4. I have tried uninstalling, clearing the C:\Program Files\Notepad++ directory, downloading the zip package, and then unzipping into the directory. This makes no difference, When I double click C:\Program Files\Notepad++\notepad++.exe, the same warning message as #3 appears.

    5. I have tried restarting the computer, and this makes no difference.
    6. I have tried uninstalling and then installing v6.5.3 instead, and this makes no difference.

    Does anybody know what I may be doing wrong? Running Notepad++ in Admin mode means I cannot drag and drop documents, which makes it much more difficult to use.

    Thank you.

     
  • Andreas Jonsson

    Andreas Jonsson - 2014-03-21

    Go to the directory where N++ is installed, right click on notepad++.exe, select Properties, select the Compatibility tab, uncheck "Run this program as administrator". Might work.

     
  • Andy

    Andy - 2014-03-21

    I found "Run this program as administrator" checked and greyed out. I had to click the "Change settings for all users" button underneath before a new pop-up window allowed me to uncheck it.

    After that it works a treat. Thank you very much for your quick response.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks