How to keep Notepad++ from auto-scrolling to the left when clicking a blank line?

Richard
2014-03-18
2014-03-19
  • Richard

    Richard - 2014-03-18

    If I'm scrolled to the right and I accidentally click on a blank line above or below the line I'm working on, Notepad++ whips back to the left to show the cursor at the beginning of the blank line.
    This happens to me frequently and it's really irritating. It's one of the things I hated most about Windows Notepad.
    Is there any way to disable it in Notepad++?
    The closest thing I've found is enabling 'virtual space' (via a plugin and a bit of code/script) but that's not quite what I want. I just want the auto-scrolling to stop when I click on a blank line.

     
    Last edit: Richard 2014-03-18
  • Alex

    Alex - 2014-03-19

    Sorry I havent seen that option on Npp and I sorely miss that feature too.

    In TextPad, it is called "Constrain the cursor to the text only" so these unwieldly jumps doesn't happen.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks