Hans - 2008-07-31

I have Windows set up for both Romanian and American English languages.  When in Unicode mode, Notepad++ can copy and paste Romanian characters fine (chars: ăîâţş) but when I switch to the Romanian keyboard, the characters appear as:

ă = ETX (one character)
ş = _
ţ = c
î = î
â = â

I've tried all of the format settings but they all do the same thing.  I like Notepad++ a lot but due to research, I have to be able to quickly switch between Rom. and Eng. without individually copying and pasting characters from different text sources.

Does anyone know how to fix this by any chance?  Hopefully I'm just missing something. 

Thanks!