Stops responding when I type

Fonebone
2014-07-07
2014-07-07
  • Fonebone

    Fonebone - 2014-07-07

    I am trying to edit a pretty large CSV file (length: 43022984, lines: 414137). I was doing regular expression search/replace operations with no problem, then today right after opening the file I simply put the cursor in the middle of a line, backspace deleted a few characters, and then tried to type and it quit responding. I uninstalled/reinstalled, same thing happens. Renamed the plugins folder, still happens.
    When I type, delete, etc into a blank new file there doesn't seem to be a problem. When I copied the first 500 lines to a new file and tried it there was no problem. When I'm in the large file I can position the cursor and type (after a slight lag), I can cut/paste, I can backspace delete, but if I try to type something where the cursor is after deleting, it stops responding. OK while I was typing this I left it not responding in the background and after about 5 minutes it finally recovered, but it happens right away again as soon as I delete then type. It really seems to have to do with the size of the file - perhaps someone else could replicate this with a similarly sized one?

    Here's my setup:
    Notepad ++ v 6.6.7 Build time Jun 24, 2014 - 22:16:54
    Windows 7 Professional, SP1, 64-bit
    Equus Nobilis, Pentium Dual Core E5400 @ 2.70 GHz, 4GB RAM

    Thanks

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks