Plugin upd.: not possible validate integrity

  • fb16

    fb16 - 2012-10-22

    Hello all,
    Today I've tried to update some plugins in NPP++ (6.1.8). I went in: "Plugins > Plugin Manager > Show Plugin Manager > Updates > HTMLTag (checked) > Update (button)". What does this warning mean?

    It has not been possible to validate the integrity of 'HTMLTag-entities.ini' needed to install or update the plugin. Do you want to copy this file anyway (not recommended)?

    I clicked "No" and installation ended without updating the plugin. The same happens also when updating another plugin: "SourceSwitch".

  • fb16

    fb16 - 2012-10-22

    Just for more clarity, here is a screenshot showing the warning message above:

  • Dave Brotherstone

    It's been defined wrong in the admin system.  I'll fix it tonight.  You can safely ignore the warning (so click "si" / "yes") - the .ini files are being validated although they don't need to be.

    Thanks for the report.

  • fb16

    fb16 - 2012-10-22

    Also applies to the "SourceSwitch" plugin?
    BTW: great new features in the HTMLTag plugin. Thank you!

  • Dave Brotherstone

    Sorry, upgrading my internet connection at home hasn't gone well… I should have known, deutsche telekom,  it was never going to go well! Anyway, I've got very limited connectivity at the moment. Hopefully it will be fixed in the next few days.

    As far as I know, same goes for source switch. If it gives the warning for non executable files, (e.g. Ini files, txt files etc) then you're fine to ignore it. If it's a dll or exe, then don't install it, and report back here if you can so we can investigate further.


    • son0fhobs

      son0fhobs - 2013-02-10

      I'm getting the same error with source cookifier, "It's not been possible to validate the integrity of 'Source Cookifier.dll'..."
      I've checked several times in the past week. Any suggestions? I'm holding out for now, but looking forward to using it.

  • fb16

    fb16 - 2012-10-22

    No worries, you have my sympathies for troubles upgrading internet connection.
    Actually, I'm not able anymore to check if it gives the warning for non executable files, currently, since Notepad++ Plugin Manager doesn't show me "SourceSwitch" for updating (see image below). fb16

  • Jason Harris

    Jason Harris - 2012-10-23

    I've tried the installing the following plugins through the plugin manager, all with the same error ("It has not been possible to validate the integrity of '<pluginname>.dll' …").   

    Code Alignment
    Document Monitor

    In the plugin manager, i went over to the installed tab, checked "plugin manager", then clicked the reinstall button.   "It has not been possible to validate the integrity of 'PluginManager.dll' …"

    This is my first time with Notepad++.  Is this normal expected application behavior ? 


  • Jason Harris

    Jason Harris - 2012-10-24

    Thank you davegb3,  that was indeed the issue.

  • fb16

    fb16 - 2012-10-25


    If it's a dll or exe, then don't install it, and report back here if you can so we can investigate further.

    Sorry, before I didn't observed that the "SourceSwitch" plugin wasn't anymore in the list of my installed plugins, hence no updates could have been available through the Plugin manager console!

    I've just tried to re-install it, using the Plugin manager, but the warning came back again. It reads the file is  "SourceSwitch.dll".

    I clicked "No", and installation ended without installing the plugin.

    Best regards

  • Gary

    Gary - 2013-04-30

    Along the same lines, for a number of days (perhaps even a couple weeks) I've been getting the error 'It has not been possible to validate the integrity of mimetools.dll needed to install or update a plugin.' when trying to update the Mime Tools plug-in from v1.7 to v1.8.


    Last edit: Gary 2013-04-30
    • Yak

      Yak - 2013-06-16


      I've been having the same problem with updating Mime Tools for a few days or weeks. I keep on refusing the upgrade, hoping that the next time it asks to upgrade everything will be okay.

      • Dave Brotherstone

        I can confirm this wasn't setup right in the repository. I've corrected it
        now, and just released the changes that have been applied in the admin
        system. That means any plugin authors who haven't updated their own
        entries are not in the repository. I've not had time to go through the
        forum and make sure everything is updated, and as I'm going away shortly I
        won't have time to do it for a while.

  • Buddy_H

    Buddy_H - 2013-07-03

    Hi all,

    Right now, the "Emmet" plugin's "EmmetNPP.dll" can't be validated.
    Same with "Notepad#" and "NotepadSharp.dll".


  • Buddy_H

    Buddy_H - 2013-07-22

    Hi again,

    "Source Cookifier" with its dll is also not validated at the moment.

  • Ben Voris

    Ben Voris - 2015-02-27

    This problem seems to have come again. See also #5145 Plugin Manager and Translate.

    I have Notepad++ Plugin Manager with Notepad++ Je suis Charlie edition "Build time: Jan 10 2015 - 17:20:21" (no version number).

    For me, I get this error for NotepadSharp.dll, NotepadStarter.exe, and SessionMgr.dll

  • GerdB

    GerdB - 2015-05-06

    I also get this for "DSpellCheck.dll" and "NppFTP.dll" (NPP 6.7.5, PM 1.3.5)

  • Patrick

    Patrick - 2015-05-06

    I also get this for "DSpellCheck.dll" and "NppFTP.dll"

  • John Beranek

    John Beranek - 2015-05-06

    Same here for:


      File: plugin1\dowF055.tmp
    CRC-32: 553e51e5
       MD4: 35667b6dc371754086f85a3362101574
       MD5: ddbe925412779949e09617791be1af99
     SHA-1: 28c15d0d1115dcaff13d871f45eb0c2cdb8e8377
      File: plugin1\DSpellCheck.dll
    CRC-32: a58c0e36
       MD4: 4908b8045a4dc9eb661cbb7fad175c57
       MD5: aa7ee7afe3856b2684a8810382fc32ab
     SHA-1: 6418a154c6b44bd3890bf28110407838531c47b3


      File: plugin2\bin\NppFTP.dll
    CRC-32: 7c602aba
       MD4: 59f2ed979438228b042ca99625a5f98c
       MD5: fc7940ff08ea9b7c29674fb4b24eb9a2
     SHA-1: 666adfbc7ed37294388818f2100f41dc51c94f0a
      File: plugin2\doc\license_libssh.txt
    CRC-32: 2aa14968
       MD4: eea5626bcceeba947919e9a8cae60bfe
       MD5: 036397d7b871a94fb072df212142f418
     SHA-1: d4de13b8d612dc65e6f29e7c4d4bbbd1eda4629d
      File: plugin2\doc\license_NppFTP.txt
    CRC-32: ba8cd1a6
       MD4: 11f03749e952ac6489dcf12c27b8d6c0
       MD5: 3c34afdc3adf82d2448f12715a255122
     SHA-1: 7713a1753ce88f2c7e6b054ecc8e4c786df76300
      File: plugin2\doc\license_OpenSSL.txt
    CRC-32: 984ef2ee
       MD4: 6cce4e28151792c50de511b2aacb3f25
       MD5: 122137a052f35dd5f83e13ad8509548d
     SHA-1: 558abae98ff07392d6866a44c5bc3d2e0bbd02e4
      File: plugin2\doc\license_TiXML.txt
    CRC-32: 8a0f9d77
       MD4: 7188b9c59f9a6e3df8dcc080ff83ec23
       MD5: d50116c3a7e715a3f5fdf270e468caeb
     SHA-1: bb7aa0345d5f576aa39564cdb74ab221be9f5677
      File: plugin2\doc\license_UTCP.htm
    CRC-32: db7d97d9
       MD4: b237da0b7a43dfa302e15541db13e455
       MD5: 53fcf5862acb0a5fc8424a5d3a9e1f78
     SHA-1: 76726094844648d3d4d1c6b5ebe5061676d6135d
      File: plugin2\doc\license_ZLIB.txt
    CRC-32: 35d38f19
       MD4: 00422be405045b56070561416921cfcc
       MD5: 9b61ea57b0310c71dd705c4750d8d77c
     SHA-1: 40b43a1ff7283c768cd311688156ee768cecac6e
      File: plugin2\doc\Readme.txt
    CRC-32: 6ffa8c72
       MD4: f477cec63fff615483649c6c6d38ec5d
       MD5: e11c2c4745b0cf94c9edb540d0a0e771
     SHA-1: 28e00ba344209c72ac0292d56c24b87e4c169f15
      File: plugin2\dowC6F6.tmp
    CRC-32: f1e84c52
       MD4: e20202b530713e6dba4d3198b6afe6ba
       MD5: b2e9cd3b7849c089db248d25d11f6f5e
     SHA-1: 88696b57a30d20dfbd2ad4e961b7303af3ed58ff
  • brownbeard

    brownbeard - 2015-05-07

    I'm having the same problem installing today as well. This seems to have disappeared for a while and recurred recently perhaps? (based on the comment history)

    I just downloaded the Windows installer for 6.7.7 (build time: Apr 16, 2015 - 00:39:44), and as soon as I opened it, I started the plugin upgrade, which game me this alert for both of the recommended plugin updates.

  • Dave Brotherstone

    Fixed - the MD5sums in the admin system hadn't been updated (either that or it's really an invalid version - I'm assuming the MD5sums just weren't updated).

    I've updated NppFTP and DSpellCheck, and they install fine now. Let me know if there's any others.

    Incidentally, this is supposed to come out in the testing, but it seems there's an issue with the test system that ignores the errors. I'll look into fixing that.

    Also, this is often missed as it's an non-obvious step in the admin interface. I'm working on a new interface for the admin system, which will mean (much) faster updates, and more obvious steps for adding the MD5sums to the database.


  • Bo Brandt

    Bo Brandt - 2015-05-08

    Same problem with XML Tools:

    alt="Xml Tools installation error"


    Last edit: Bo Brandt 2015-05-08