Problem: using npp on nt4

DonPedro
2011-02-17
2013-06-25
  • DonPedro
    DonPedro
    2011-02-17

    hello,
    I am still using windows nt4 on an old machine. according to the systems npp should work with (all ms windows 32 from windows 95 on) it should run under nt4.
    installation went fine without problem, but when I try to start the program I get the following error-message (translated from german):

    "procedure entry point -GetLongPathNameW- can not be found in -KERNEL32.DLL"

    could this problem be dealt with somehow? (I guess it needs a change in the soucre code …)

    best regards

     
  • cchris
    cchris
    2011-02-17

    Indeed, this API is available since Win2k pro only.
    If Don wishes to retain compatibility at this level, he'll have to guard all 4 calls to it with a version check. Also, removal from recent file list will need to be attempted on both short and long file names in doOpen().

    CChris

     
  • DonPedro
    DonPedro
    2011-02-17

    thank you cchris for your answer!

    of course I really would appreciate that downward-compatibility with regards to supported operating systems.

    on the projects homepage it is stated that the program is intended to run on (quote):

    32-bit MS Windows (95/98), 32-bit MS Windows (NT/2000/XP), 64-bit MS Windows, All 32-bit MS Windows (95/98/NT/2000/XP), Win2K, WinME, Microsoft Windows Server 2003, WinXP, WINE

    so how could I get attention from the programmers to address this? do they read this forum?
    if they decide (I hope not) to abandon support for older os's they should update their homepage ….

    any way, thank you (to the the programmers) for all your efforts put into this fine piece of an editing tool!

     
  • cchris
    cchris
    2011-02-18

    They read this forum. However, since you found a behaviour contrary to the stated specifications, it is a bug until either changes to match.
    Since it is a bug, it is even better to post it on the Trackers / Bugs interface, on the SF menu bar close to th top of this page.

    CChris

     
  • Ronan Jouchet
    Ronan Jouchet
    2012-01-24

    Hi!

    What is the latest version supported by Notepad++ on NT4SP6? I don't care about running the latest version, I just want something better than notepad on an old NT4 box I need to extract data from :D
    - When trying to install 5.9.8 on this old thing, the installer returns "npp.5.9.8.Installer.exe is not a valid Windows NT application".
    - When installing it on another machine and copying the binaries to the nt machine, the error mentioned by the original poster pops up.

    Thanks.

     
  • nateman1352
    nateman1352
    2013-06-25

    I did some trial and error and found that Notepad++ 4.6 is the latest version that runs on NT4