Strange symbols on my pc icons.

2009-12-29
2014-03-17
1 2 > >> (Page 1 of 2)
  • Karl Sultana

    Karl Sultana - 2009-12-29

    Hi,

    I noticed strange symbols, screenshot of an ex here: http://tinyurl.com/ychfr2x Now I'm thinking it's because I installed notepad++ maybe.

    do you know how to fix this problem please? So far I only saw that problem on icons of text files.

    Thanks,
    Karl

     
  • cchris

    cchris - 2009-12-29

    I have never seen this icon; please review your installed software for anything that may have commandeered the .txt file extension. What application opens when you double click such an icon?

    CChris

     
  • Karl Sultana

    Karl Sultana - 2009-12-29

    It's a text file and notepad opens up when I double click it. I'm just trying to see if Notepad++ created this problem, I don't know of any other software I downloaded that can do this.

    Karl

     
  • elpepe

    elpepe - 2009-12-29

    I have the same problem. I already tried many things: registry settings, changed icon from the "File Type" tab of the Windows Explorer preferences etc. Nothing happened. The icon is not shown and it seems that it is not recognized by my Windows XP SP3 (32 bits)

     
  • elpepe

    elpepe - 2009-12-29

    Well, I've solved the issue with icons!. In my home PC I've installed Notepad++ in English without problems. In my work PC I installed Notepad++ in Spanish. It seems installation is diferent because it did not register the NppShell_01.dll. I opened a command shell in the Notepad++ folder and type:"regsvr /s /i NppShell_01.dll". This open the Context  Menu and the Icon options for Notepad++. I choose the classic icon and then reset the PC … and voilá, everything is OK now.!

     
  • elpepe

    elpepe - 2009-12-29

    Sorry the right command is:"regsvr32 /s /i NppShell_01.dll"

     
  • Karl Sultana

    Karl Sultana - 2009-12-30

    Hi,

    May I know how to open a command shell in the Notepad++ folder please?

    Karl

     
  • cchris

    cchris - 2009-12-30

    It depends on your file manager. Some have an option called DOS prompt here, or similar. In vintage Explorer, I don't know where that would be. You can always go to Start menu -> Run…, enter "cmd" and validate. In the console that pops up, cd to the desired folder.

    CChris

     
  • Karl Sultana

    Karl Sultana - 2009-12-31

    Hi,

    I was able to open cmd and type the command, so that's all?
    Here's a screenshot of what I did in cmd:
    http://tinyurl.com/yb643f2

    Thanks,
    Karl

     
  • cchris

    cchris - 2009-12-31

    Ok, I'm happily surprised that it didn't complain about the file not being found. Did this fix your issue?

    CChris

     
  • Karl Sultana

    Karl Sultana - 2010-01-01

    Yes, so far it's ok.. but I'll wait to see if it remains like this!

    Thanks!
    Karl

     
  • Karl Sultana

    Karl Sultana - 2010-01-02

    Issue is not fixed. I still see these icons - btw not all text file icons, ONLY those on my desktop.

     
  • cchris

    cchris - 2010-01-02

    Try rebuilding the icon cache, it probably didn't get refreshed. Changing the colour depth is reported as a simple, effective way of doing it, at least under XP.

    CChris

     
  • Karl Sultana

    Karl Sultana - 2010-01-02

    How do I do that please? I have vista.

    Thanks

     
  • elpepe

    elpepe - 2010-01-26

    Well…, nothing is perfect! I updated Notepad++ to 5.6.4 unicode on my home PC and the icons of the associated files are not shown properly anymore…This time nothing worked, neither ''regsvr32 /s /i NppShell_01.dll" (worked in my office PC) nor the repair icons option of PowerToys TweakUI, nor the File Types tab association of each type to Notepad++. I saw many issues about icons and I know it is not a big deal but at least makes me feel uncomfortable with the application. Why it is happening so frequently? And moreover even if there's no will of solving it at least a kind guide about how to repair or diminish the issue will be very appreciated.

     
  • Harry

    Harry - 2010-01-26

    A quick google shows that some backup applications cause the/a green tick to be shown in files, like the one in the first screenshot. N++ nor the NppShell extension make use of any such overlay icons. NppShell draws a black square by itself, anything else is most likely from another extension/program (unless something really, really weird is going on).

    gorosito:
    By "not shown properly anymore", what exactly do you mean? Is no icon shown at all, is it the wrong icon (like the generic unknown file icon) or something else? Could you provide a screenshot? Also, you mentioned you ran XP, is that still the case for the computer you mentioned?

    Does completely removing the shell extension help? I'd like to know to what extend it is the cause of your problems. A quick manual way to remove it's icon association is to find the "Notepad++_file" key in the registry under HKEY_CLASSES_ROOT, and remove the shellex key (export the notepad++_file key first as a backup. If you want to completely reset it, remove the entire notepad++_file key)

     
  • elpepe

    elpepe - 2010-01-27

    harrybarry, The icon shown is the generic unknown file icon. I also tried to remove the shellex key but it is not allowed….

     
  • Harry

    Harry - 2010-01-27

    Not being allowed to remove the key means oyu have no administrator rights. Try using an account that has them (or start regedit with the proper credentials), otherwise I cannot be of much help, as the entire icon association happens in the registry.
    But if the generic icon is shown, it may very well be the shell extension fails to load. Try getting into the settings dialog, that will at least tell you if you have the correct version by just showing up (32 vs 64 bit) (regsvr32.exe /i /n NppShell.dll in the n++ folder).

     
  • elpepe

    elpepe - 2010-01-27

    harrybharry, I'm the administrator of both equipment. I'm not a basic user and in the past I made a lot of hacks to tune my equipments to my personal taste. This includes of course registry modifications amongst others. I really don't remember any time when I was not allowed to delete a key…, that's why I'm remarking this fact.
    Nevertheless I tried your suggestion which is the same I already done but WITH notification and I've got a  "DllInstall in NppShell_01.dll succeeded" message, but nothin changed. Unknown file type icon is again shown for all the files associated to Notepad++..

     
  • Harry

    Harry - 2010-01-27

    That's strange, I'd say the admin sohuld be able to delete any key, maybe somehow the permissions were lost? You can access those via regedit as well, similar to those of files (I dont know the details, but giving owner and admin write rights sohuld do it I suppose)
    As for the notification, doesn't any dialog show up? The whole idea of DllInstall is to show the configuration dialog (its not according to what the shellextensions/regsvr32 specs say, but its a quick and easy way to do it ;] ). If that doesn't show up, maybe the shell extension is out of date

     
  • elpepe

    elpepe - 2010-01-27

    Yes of course the dialog show up and I set all the stuff as I like: show contextual menu item, classic icon, no dynamic icon etc, but still nothing happens. Making exactly the same stuff in my PC at work it succeed, without deleting no registry key…but not at home…I am frankly astonished with this problem. Anyway as someone wrote down here or there, it is just an icon, any other stuff with Notepad++ is ok but it's a pitty that the icon problem is not solved yet. I mean that I'm not the only one with the problem so I guess is more than a simple personal configuration sutff

     
  • Harry

    Harry - 2010-01-27

    Well, a possibility could be that because you didn't have any permissions on that registry key, that the extension GUID points to an older version and couldn't be updated when a newer version is installed. At this point I'm merely guessing. Changing the options in the dialog shouldn't affect the icon in such a way it reverts the the unknown file icon. Could you make an export of the following keys and post them here? That might make debugging the issue a little easier (I realize it's just an icon, but it's annoying, looks awful and it means there is some underlying problem somewhere), if you have the time:
    HKEY_CLASSES_ROOT\Notepad++_file
    (on 32 bit system:)
    HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Notepad++
    HKEY_CLASSES_ROOT\CLSID\{00F3C2EC-A6EE-11DE-A03A-EF8F55D89593}
    (on 64 bit system:)
    HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Notepad++64
    HKEY_CLASSES_ROOT\CLSID\{B298D29A-A6ED-11DE-BA8C-A68E55D89593}

    If you find a 32 bit version on a 64 bit system, or vice versa, could you post those as well?

     
  • elpepe

    elpepe - 2010-01-28

    Ok, here are the keys you asked:

    @="Notepad++ Document"
    "EditFlags"=hex:00,00,00,00

    @="\"%1\""

    @="open"

    @="\"C:\\Program Files\\Common Files\\Microsoft Shared\\OFFICE11\\MSOXMLED.EXE\" /verb edit \"%1\""

    @="\"C:\\Program Files\\Common Files\\Microsoft Shared\\OFFICE11\\MSOXMLED.EXE\" /verb open \"%1\""

    @="{AB968F1E-E20B-403A-9EB8-72EB0EB6797E}"


    @="{00F3C2EC-A6EE-11DE-A03A-EF8F55D89593}"


    @="Notepad++"

    @="C:\\Program Files\\Notepad++\\NppShell_01.dll"
    "ThreadingModel"="Apartment"

    "Title"="Edit with &Notepad++"
    "Path"="C:\\Program Files\\Notepad++\\notepad++.exe"
    "Custom"=""
    "ShowIcon"=dword:00000001
    "Dynamic"=dword:00000001
    "Maxtext"=dword:00000019
    "IconID"=dword:00000000

     
  • Harry

    Harry - 2010-01-28

    That clarifies a few things. It appears microsoft Office managed to wedge itself into the icon handler keys, rendering the n++ shellextension helpless :) (maybe a bit exaggerated).
    The open and edit commands both point to some office XML application, and the icon handler does so too
    (on my system it identifies itself as
    C:\Program Files\Common Files\Microsoft Shared\OFFICE12\MSOXEV.DLL
    )
    I'd suggest just removing the whole notepad++_file key and reinitializing it by using the notepad++ file association tab, but you needs the write rights to do so. I have absolutely no idea how this could have happened though.

    (Note: the context menu handler is set correctly, so you should see the proper "Edit with Notepad++" item in the context menu, next to some open and edit commands that open office)

     
  • elpepe

    elpepe - 2010-01-29

    Well, finally I could solve this issue. But…what I needed to do is to change the permissions of the HKEY_CLASSES_ROOT\Notepad++_file key. This is made by right clicking over the key and go to Permissions. Even when my user was an admin, I was not in full control of the key. I don't know why…, then I could delte the key. After that I went to the File Types  tab of the folder Options menu and change the association of .txt files to Notepad++ (it is already done but it seems to be confirmed) and that's all. All the associated files types suddenly appears with the Notepad++ icon!.
    Thanks everybody for trying to help me.

     
1 2 > >> (Page 1 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks